Issue suddenly with HTTPS Get - because of v3.1.0?

Hi all,

I'm doing a HTTPS GET for MyEnergi data, but I'm suddly getting an error within Node-Red

RequestError: write EPROTO C027C1C9E67F0000:error:0A00010B:SSL routines:ssl3_get_record:wrong version number:../deps/openssl/openssl/ssl/record/ssl3_record.c:355:

However, when I put the URL "[*]" in a browser, and enter my creds, it retrieves the data perfectly

I think my system was automatically upgraded to v3.1 and it broke then

Thanks in advance

Did you also upgrade your version of Node.js?

Automatic update is not a standard feature of Node-RED. How / where do you run node-red?

What version of nodejs are you running?

Were you previously using a different version of nodejs?

I have somehow ended up with v3.1.0. I did a general update of my Linux Mint with apt-get upgrade.

If I downgrade nodejs (I think I was on v18.18.0, can I then downgrade Node-Red?

Or can I resolve my issue without doing that ?

If you upgraded to a new major version of Node.js, you need to rebuild your node.js modules with something like:

cd ~/.node-red
npm rebuild

So can I go back to Node-Red v3.0.x ?

Well, you can. Node-RED is a node.js app so you can install any version you like. However, you will like still have the same problem. First you should follow my suggestion and see if that fixes it.

What's the best way to find the location of /.node-red ? It's not in the root.

If you start node-red in a command window it will tell you where it is.

1 Like

Or do a filing system search.

The default location is the home folder of whatever user is running node-red.

This is all documented.

Many thanks for your replies

No joy with the npm rebuild

I found a posting about adding options (permitting older TLS versions) when launching node-red. I launch it automatically at startup using PM2.

Where would I go to edit the script that is used to launch node-red to now add an option ?

BUMP again :grinning:

You will want to find out how pm2 is configured. It has its own configuration files.

As maybe I've mentioned (I forget), I install my instances of Node-RED in a much more "node.js like" way which avoids a lot of these issues. See my alternate installer on GitHub for details if interested.

Did you try to enable the SSL/TLS and then uncheck "verify server verification" in the tls config ?

I've no idea what you mean, sorry. Can you point me towards something which gies a step by step on this ?

In the http request node: click "Enable secure (SSL/TLS) connection"
Click the icon on the right
uncheck:Verify server certificate

Update > done > deploy

Unfortunately, no joy with that

Just to confirm for the benefit of anyone else with similar issues - I did a full new install, using v3.1 too, and everything works

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.