KnowGo Simulator not working with the http request node


I have been using the KnowGo Simulator for the last approximately 3 weeks now and I was using a default node in Node-Red called http request to get/post information from their Rest API using the localhost:8086 URL and the specific endpoints mentioned on their website which is: REST API - KnowGo Vehicle Simulator.
The application can be easily installed using the Microsoft Store from Windows.
This has worked great and all the requests were successful. Recently in the past couple of days I have discovered that the connection is not longer working and it's giving me the following error: "RequestError: connect ECONNREFUSED : ...". It gives me the following error when I try to access the URL from Node-Red although if I paste the link directly into the browser, the get result is successful as well as in Postman, the result is successful, so it does not seem to be a problem with the simulator itself, as no any recent updates were released.
I will also attach my node settings and mention that for the KnowGo Vehicle Simulator I have the option for Unauthenticated REST API Access ticked which means I can simply call the endpoints without any authentication details, but I have also tried generating a Bearer token from the application and the result is still the same as in the image above.
The flow itself is a very simple one for testing containing an inject node, http request node and a debug node.
Other troubleshooting steps I have taken is reinstalling the simulator, reinstalling Node-Red, trying all sorts of steps mentioned online in regards to the ECONNREFUSED error message such as disabling firewall, flushing dns, trying to access Node-Red in incognito mode, also I checked the netstat command to look for the specific 8086 port used by the API and I couldn't find it using any of the additional options netstat has, and so on but none of these steps actually solved the issue. I have also tested the http request node with other APIs and those seem to be functioning correctly.
Do you have any ideas as to why this has happened? It was working perfectly fine until now I was able to successfully call the API from Node-Red and I am not really sure what might have happened.

Additional replication steps are as follows:
First download and install the node.js from their official website.
Install node red using the specific command.
Open Microsoft Store and search for KnowGo Simulator, download it and install it.
Ensure you have the option Unauthenticated REST API Access ticked to avoid any authentication details in the http request node.
Open node red and call an endpoint available on the website above.
Expected result: get the specific result for the call.
Actual result: The ERCONNREFUSED will appear in the debugger.

If you have any ideas, or you can find a fix it would be very helpful. Thank you in advance.

Kind regards,

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.