Library error? Can not install a node from the library,

#1

I am trying to install the

npm install node-red-contrib-simple-message-queue

I cut/pasted that into my machine.

I get an error:

0 info it worked if it ends with ok
1 verbose cli [ '/usr/bin/node',
1 verbose cli   '/usr/bin/npm',
1 verbose cli   'install',
1 verbose cli   'node-red-contrib-simple-message-queue' ]
2 info using npm@5.6.0
3 info using node@v8.11.3
4 verbose npm-session 94545e99123dfdfa
5 silly install loadCurrentTree
6 silly install readLocalPackageData
7 silly fetchPackageMetaData error for node-red-contrib-simple-message-queue@latest request to https://registry.npmjs.org/node-red-contrib-simple-message-queue failed, reason: getaddrinfo ENOTFOUND registry.npmjs.org registry.npmjs.org:443
8 verbose type system
9 verbose stack FetchError: request to https://registry.npmjs.org/node-red-contrib-simple-message-queue failed, reason: getaddrinfo ENOTFOUND registry.npmjs.org registry.npmjs.org:443
9 verbose stack     at ClientRequest.req.on.err (/usr/lib/node_modules/npm/node_modules/pacote/node_modules/make-fetch-happen/node_modules/node-fetch-npm/src/index.js:68:14)
9 verbose stack     at emitOne (events.js:116:13)
9 verbose stack     at ClientRequest.emit (events.js:211:7)
9 verbose stack     at TLSSocket.socketErrorListener (_http_client.js:387:9)
9 verbose stack     at emitOne (events.js:116:13)
9 verbose stack     at TLSSocket.emit (events.js:211:7)
9 verbose stack     at emitErrorNT (internal/streams/destroy.js:64:8)
9 verbose stack     at _combinedTickCallback (internal/process/next_tick.js:138:11)
9 verbose stack     at process._tickCallback (internal/process/next_tick.js:180:9)
10 verbose cwd /home/pi/.node-red
11 verbose Linux 4.9.52+
12 verbose argv "/usr/bin/node" "/usr/bin/npm" "install" "node-red-contrib-simple-message-queue"
13 verbose node v8.11.3
14 verbose npm  v5.6.0
15 error code ENOTFOUND
16 error errno ENOTFOUND
17 error network request to https://registry.npmjs.org/node-red-contrib-simple-message-queue failed, reason: getaddrinfo ENOTFOUND registry.npmjs.org registry.npmjs.org:443
18 error network This is a problem related to network connectivity.
18 error network In most cases you are behind a proxy or have bad network settings.
18 error network
18 error network If you are behind a proxy, please make sure that the
18 error network 'proxy' config is set properly.  See: 'npm help config'
19 verbose exit [ 1, true ]
0 Likes

#2

What does 18 say ?

1 Like

#3

Well, if there was a network problem, I would not be able to connect to the machine and not post these messages.

So although 18 says there is (or infers) there is a network problem, I can't quite see how, if I am able to access the internet.

Though, now looking at it, there seems to be a DNS problem on the machine.
Dunno how/why, as it usually works, and as far as I know, I haven't changed anything.

Thanks.

0 Likes

#4

Schroedingers Network? :slight_smile:

1 Like

#5

And if there is "no network" how can it find the nodes available when I search for them?

Anyway, I'm looking at it.

Been away for a while - as "you" may have noticed (no flooding with questions) - so I shall see what the Gremlins have been doing in the mean time.

0 Likes

#6

Did you try installing from the Node Red menu "Manage palette" as well?

0 Likes

#7

Yes, originally from NR and "Manage Palette".

Failed.

So I tried form the CLI and it failed there too.

As mentioned: If it can find it when I search for it, then there is a visible network - right?

0 Likes

#8

A lot of people have been downloading it. Are you behind a proxy?

0 Likes

#9

I hope not! :wink:

Seems the DNS is stuffed up.

I can ping 8.8.8.8 but can't ping google.com

Hmmmm....

0 Likes

#10

Nameserver?

0 Likes

#11

Well, if I can ping 8.8.8.8 and it works, but when I say ping google.com it just falls over, that's a DNS lookup problem - yes?

Or at least indicative of a DNS problem.

0 Likes

#12

Yes, a DNS problem. Try setting your Nameservers by hand to 8.8.8.8, 8.8.4.4 (if they aren't already!)

0 Likes

#13

(BIG BLUSH)

Dunno what happened.

Now it is working.

Sorry folks.

May have to have words with the minion who was looking after the system for past few days.

0 Likes