OSC installation help

#1

hi!

im fairly new to using node-red and npm. im having a little trouble installing the osc node and i was wondering if i could get some insight as to what exactly my errors are with this install. i have copied and pasted the npm error log on here.

0 info it worked if it ends with ok
1 verbose cli [ '/usr/local/bin/node',
1 verbose cli '/usr/local/bin/npm',
1 verbose cli 'install',
1 verbose cli 'node-red-contrib-osc' ]
2 info using npm@6.7.0
3 info using node@v11.10.1
4 verbose npm-session 6d8dd15266cb71df
5 silly install loadCurrentTree
6 silly install readLocalPackageData
7 silly fetchPackageMetaData error for node-red-contrib-osc@file:node_modules/node-red-contrib-osc Could not install from "node_modules/node-red-contrib-osc" as i
t does not contain a package.json file.
8 timing stage:rollbackFailedOptional Completed in 1ms
9 timing stage:runTopLevelLifecycles Completed in 1340ms
10 verbose stack Error: ENOENT: no such file or directory, open '/Users/"----"/.node-red/node_modules/node_modules/node-red-contrib-osc/package.json'
11 verbose cwd /Users/"----"/.node-red/node_modules
12 verbose Darwin 18.2.0
13 verbose argv "/usr/local/bin/node" "/usr/local/bin/npm" "install" "node-red-contrib-osc"
14 verbose node v11.10.1
15 verbose npm v6.7.0
16 error code ENOLOCAL
17 error Could not install from "node_modules/node-red-contrib-osc" as it does not contain a package.json file.
18 verbose exit [ 1, true ]

#2

Have you tried with the recommended versions of nodejs? see the docs on the website

#3

The version of node has nothing to do with the actual error message.

Exactly what npm command have you run to get this log?

#4

im running the command:
npm install node-red-contrib-osc

also, i did try installing this from "manage palette" in user settings and got the same error message.

in addition, i am using midnight commander to navigate to the node module path and then running the command once i am in that path. would this make any difference? im assuming this would be the same manually setting the directory path for this installation.