Memory spikes - no idea why

Hi again,

A bit desperate on this one.
I'm running several containers in BalenaOS (as project as (aged) student). The most important ones being node-RED and a postgresql db with postgis extension.

I am loading a geojsonfile with coordinates into worldmap (with a split and delay node).
I have been experiencing a spike of mem usage by node red when I load the file for a second time.
Mem usage goes up to over 1GB (Max noticed 1.5 GB) as seen on my rpi4 and stays there. Doesn't go higher when reloading the file for a third or fourth time, doesn't drop either.

As the usage is focused on the use of rpi3B+, this poses a problem.
I have been cleaning up nodes, flows, replacing function nodes with switch and change nodes,...
Eventually the problem seemed solved and the usage of Mem is limited to 100-150 MB.

But suddenly the problem comes back when I for instance activated a disabled track-node. Disabling again doesn't solve the issue.

Fact is it could be anything. Could be when I import 5 nodes from an other project or anything. I can't pinpoint it to any specific node.

For the moment I have it under control again, but it is only a matter of time till I'll be confronted with it again.

I've put an overview of my flow as attachment. (A work in progress, looks really messy for now)

Any ideas in which direction to look would be welcome. :slight_smile:

Node-Red v2.1.4

Thanks,

Are you viewing the worldmap with a browser on the Pi, or from another computer?
What browser do you use?

Looking from another computer. Pi runs headless with BalenaOS (docker environment).
Browser on my computer is Chrome.

Okay so it's not the browser hogging the memory (for once!).

I am not familiar with BalenaOS or Docker. (Tried it once, it made life too complicated)