Mh-z 19 & sds011

Hello !
I am completely new here and also new to node red & RaspberryPi in general, so I need some help of you.
I want to connect the two sensors MH-Z19 & SDS011 to my RaspberryPi4B to show their data on the node red dashboard and have some problems with it.

First to the MH-Z19, the node red website tells me that i have to enable the serial port in raspi-config. I did that but i constanly get this report when i try to get the co2 data in the debug window.
"Error Resource temporarily unavailable Cannot lock port". I got a hint that I shoul disable bluetooth, i did that too but get the same report.

I connected the SDS011 via USB to my Raspberry PI and the node itself says "connected" under it, but i cant get any information from it in the debug window. I get the report " TypeError: Cannot read property 'command' of undefined". I think its a problem with the infject node, but i am not sure.

What i noticed, is that both of the Sensors use the same serialport, /dev/serial0 in the properties.
Of curse i tried to use the sensors separtately, but i still get the same reports.

I have a feeling that these problems are easy to solve, but because this program is totaly new for me in general, I just don't get it.
So i hope someone here can help me with it.

Best regards.

As for the mh-z19, have you followed the directions in the ReadMe for the pin connections?

As for the sds011, node-red-contribute-sds011 hasn’t been updated in over two years and is no longer supported by the author.

You should look to see if you can find another way (python maybe) to access the device and then call it via the `exec node.

Hello @zenofmud , thanks for your reply.

As for the MH-Z17: Yes, I Connected the it just like it's told on the website. The sensor itself also blinks when connected. I think i get the report because the /dev/serial0 is already used, is there any way to show all the serial or URAT connections of the Pi to see wich one i should disable that the MH-Z19 can work? Or is the report i get a common one and there is another way to make it work?

As for the sds011, how do i do that? I'm a total beginner, how do i access the device with python and how do i get to the exec node ?

Best regards

I solved the problem with the MH-Z19, its working ! :slight_smile:

1 Like

First off, please add an explaination of what you did to get the MH-Z17 to work for the benefit of others that might run into this issue.

The best thing to do is a google search and try the existing projects. Once you get it working outside of node red, you can try runing the program using the exec node.

Also I recommend watching this playlist: Node-RED Essentials. The videos are done by the developers of node-red. They're nice & short and to the point. You will understand a whole lot more in about 1 hour. A small investment for a lot of gain.

I just switched the node I installed.
They are two different nodes to download on node red for the mh-z19. I used the green one all the time but the light red one is the one to use.

I found this for the sds011, but i don't know how to use this information.
Do i have to create a script and copy paste things from this github or what should i do ? And if yes, where should i save this script on my pi ?
Hope someone can help me.

Green ones are flows someone has added to the library, red ones are the contributed node itself.

As for the Py-sds011, that is a python interface to the sensor. It also hasn’t been updated in three years and it doesn’t look like the author is responding to issues so it may be abandoned.