Modbus installation error in WIN10

I have installed nodejs exe from website.
used this command : npm install -g --unsafe-perm node-red
THEN started "Node-red" in command prompt and tried installing modbus node.
npm install node-red-contrib-modbus
Can anyone give me a fix for it ?

2022-09-21_17h17_11

You have to run the Npm install node-red-contrid-modbus from within your node red directory.
Most likely C:\users\rverma\node-red
Or install it from the pallet manager in Node-red dashboard, much easier.

After getting into node red director, still i get error which is shown in image. and also i tried from dashboard pallette manager but still not working.

You have spelled the node name wrong,. you have contrid and it is contrib a 'b' at the end, not a 'd'

HI,
If you see the line number 13 in image, You will se that i have written the correct command.
It is strange for me because I have installed it in another laptop and it worked as it does generally.

Ahhh missed that :flushed:

Here is a google search to help you fix it: client=safari&rls=en&q=npm+unable+to+get+local+issuer+certificate&ie=UTF-8&oe=UTF-8'

I went through the link. It shows like i am having problem because of my company's firewall or security reason. My laptop is in company domain.

You will have to get that resolved with you company's IT guys.

In future please copy/paste terminal output rather than screenshot. That makes it much easier for us

I an new here on node-red.
Can you please tell what terminal output is ?

It is what you took a screenshot of showing the errors. Copy/paste of the text is better than a screenshot.