Modbus SolarEdge SE8K RTU


Done some programming before in my life, but I thought it would be funny to start something new and so I ended up with NodeRed on a RPi3.

My neighbour does have a SolarEdge photovoltaik inverter plus a meter, according to specs working with modbus. Could be via TCP or via RTU (USB-RS485 dongle on an RPi3).

Installed the modbus contrib package to NodRed and try to read the data. When I derectly debug-print the output happening on the serial device (/dev/ttyUSB0) I do see data but it is not in a format that is readable to me. To the contrary, when I try this with the modbus-flex-getter it also does not matter, if I use TCP or RTU. Flex-getter is always initializing and then reconnecting but I can not get the connection "stable", to see anything in th modbus-read afterwards.

Could someone please give me a (friendly, please, I'm new here) nudge, to open up a new perspective to me?



I an no expert but have you tried adding a modbus response node after the nodbus read node? This response node will show you the raw data.

What value were you expecting and what are you actually receiving? A screenshot may help us in seeing what you are seeing.

Hi there,

good point. Have attached a screenshot of the actual flow


As you can see, I had tried to directly print what is on (/(dev/ttyUSB0) for ... kind of lame debug purposes, if any data is there.

The string of the raw data from the flex-getter is empty.

Thanks a bunch for your support.


This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.