Monaco editor icons missing

I recently created a fresh bullseye image on my Pi 4 and installed a fresh copy of Node Red. Here are the versions:
9 Apr 21:29:09 - [info] Node-RED version: v3.0.2
9 Apr 21:29:09 - [info] Node.js version: v16.19.1
9 Apr 21:29:09 - [info] Linux 6.1.21-v8+ arm LE

When I use the find function in the Monaco editor to search within my function node, the icons are missing (see image)

This was working perfectly in my previous install on buster. It probably was older versions of node js and Linux. How can I fix this?


Try clearing the browser cache (via the browser menus), and reload the page. Also trying another browser is a good way to elimate such possibilities.

If still no joy then open the developer console in the browser, refresh the page, and see if there are any errors.

For most browsers, ctrl-f5 (if you have function keys) will work. Edge has a right-mouse-click on the reload icon too:


Not sure whether other browsers have that.

A hard refresh is normally enough.

In firefox I had a situation, after a dashboard update, where Ctrl-f5 did not fix it, but a Clear Cache did, which is why I always tell people to use the menus. Good to know that Edge has that option on right click.

1 Like

I too have noticed ctrl-f5 failing to work on Firefox.
According to Mozilla's list of keyboard shortcuts it "overrides" the cache.
Untitled 3

It's nice to discover that Edge has a clear cache option on the reload button. Not nice enough to convince me to use it though! :balance_scale:

I am using Chrome on a PC and CTRL-F5 did not seem to work so I tried closing the browser and reopening it and now it is fixed.

Thanks for the help.

Probably best to take out browser discussions elsewhere - though I did used to use Firefox above all else for quite some years until they really messed things up and Chromium took centre stage. I used Chrome until I realised how badly behaved Google are - now I've even persuaded work that Chrome is the wrong tool for a public body and I'm on a drive to stop people declaring "Chrome is the recommended/supported browser" in their documentation. Edge is Chrome with the usage data going back to Microsoft rather than Google and knowing what I do about Microsoft, they are currently rather more trustworthy than Google are. And you certainly can't beat the useful features in Edge if you are an exensive Windows and Office 365 user.

Occasionally, hitting it a few times in succession kicks things clear. Though Colin's approach is probably more reliable :slight_smile:

I will admit that I knew nothing of it but this thread prompted me to just give it a go. :grin:

PS: Ah! I may have slightly misled people on the right-click front! Turns out that only works if you have the browser devtools open! Yikes, weird UX.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.