No editor showing after 3.0.0-beta.4 upgrade

After upgrading to the latest 3.0.0-beta.4 the editor doesn't show. Just a blank page. Tried with chrome, chromium, Edge and Safari. Same result. Tried to clean the cache but nothing changed. See screenshot.
Tried on OSX Monterey and on iPhone running IOS 15.5.
Worth to mention that the /ui shows fine.

This is usually a caching issue between upgrades.

Please check the browsers JavaScript console for any error messages.

Thx Nick. This is what I get in the console:

Problem initialising 'monaco' code editor ReferenceError: monaco is not defined
    at Object.init (red.min.js?v=3.0.0-beta.4:18)
    at Object.init (red.min.js?v=3.0.0-beta.4:18)
    at Object.init (red.min.js?v=3.0.0-beta.4:18)
    at red.min.js?v=3.0.0-beta.4:16
    at Object.success (red.min.js?v=3.0.0-beta.4:16)
    at c (vendor.js?v=3.0.0-beta.4:2)
    at Object.fireWith [as resolveWith] (vendor.js?v=3.0.0-beta.4:2)
    at l (vendor.js?v=3.0.0-beta.4:2)
    at XMLHttpRequest.<anonymous> (vendor.js?v=3.0.0-beta.4:2)

This is typical for internet explorer and old browsers that don't support esm. Which browser raised this error and what version?

Hi Steve the browser I used are:
on OSX Monterey: Safari (v16), Safari Technology Preview (v16) and Chrome (87.0.4280.88). All up to date.
On Windows 10: Edge( 103.0.1264.44 ) and Chrome (1050.5152.2).
On IOS 15: Safari.
As far I I know al the browsers are up to date.

Added a full screenshot of the console. This is Edge running on Windows 10 Pro.
Any suggestions on how to fix this?
Thanks.

Chrome 87 was released November 17, 2020

You should seriously update your browser.

Thx Steve, but I really don't use Chrome. I have it installed on my Mac but just used it to test the editor and it failed. As did Safari. On the other hand on my windows 10 machine , both Edge and Chromium ( still don't use chrome) fail.
Also chrome on my iPhone fails too (version 103.0.5060.63).
I'm not sure this is a browser issue. It's not easy to explain why out of 6 browsers on 3 different operating systems none is working.
This is happening after the last upgrade to 3.0.0.-beta.4 .With the previous beta the editor was showing.
Adding that I had a chance to try on an Android 11 device with chrome version 102 and the editor still down not show.

Some more info from the Network tab.There is an error about loading settings.
I've tried to run node-red with the following command and it's still the same:
node C:\Users\user1\.node-red\node_modules\node-red\red.js -s C:\Users\user1\.node-red\settings.js

Just a quick note. I had the very same challenge yesterday. After moving my original settings.js to settings.js.backup the editor appeared and node red provided a new settings.js.

Unfortunately I had to stop there due to other obligations, but from there everything worked like a charme.

Thx Jodel.
Unfortunately I tried it and hasn't solved my issue. I also had a backup of my settings.js and tried restoring it to no avail.

As an additional information: it did not work with safari, opera, firefox. all on an actual mac m1

This is the same for me as I have a Mac with an M1 chip. However, my node-red runs on an Intel Nuc with Windows 10 pro and even on that machine running Chromium or Edge it works. I also installed Chome Canary and it still doesn't work.

I quickly tested it again.

nodered runs on a raspberry with the following docker image "nodered/node-red-dev:v3.0.0-beta.4". If I switch to it I can only see the node-red logo on my m1 mac's browsers, a virtual intel mac browser and my virtual windows browser.

as soon as I delete my former settings.js and node-red establishes a new one, everything works on all maschines and browsers.

@podi62 I have recreated the issue and got the fix ready for 3.0.0-beta.5 - Fix defaulting to monaco if settings does not contain codeEditor by knolleary · Pull Request #3732 · node-red/node-red · GitHub

The workaround is to ensure your settings.js file contains a codeEditor property under the editorTheme setting:

editorTheme: {
   codeEditor: { lib: 'monaco' }
}
2 Likes

Thx Nick. This workaround fixed the issue.