No response from TCP request

I have a home automation server that I can communicate with simply using a TCP connection. When I test it in putty, it looks simple:

I send GET 1 and I get the data back for device 1, I send GET 2 and get the data for another device.

I did this very simple flow:

I click on inject and nothing comes out in the debug node.

Looks very simple, but I am not sure what I did wrong...

Are you using port 10000 when using putty as well?

Yes, I am using the same port.

Try this (your response from putty is 18 characters)

Nothing. I tried all options, and never get anything in the debug view. I was also monitoring node-red-log but did not see any errors.

Can you try a change node between the inject node and the TCP request node
adding a linefeed to the payload, like this:


1 Like

Damn, I could have looked at that for ages and still not realize what is wrong. Thanks a lot.
The correct syntax is:

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.