No services in "node-red-contrib-fritz"


I just installed node-red-contrib-fritz (latest version) and tried to connect it to my Fritzbox (7490, latest version) and seemingly with success. However, it doesn't find any services although it says they were received:

Any ideas what I could do?

Did you setup the config-node correct?
This works fine for me.

I have also a 7490 with firmware version 7.12, maybe in the newer version you have to enable the TR064 protocol;
Enable TR064: In the webui goto "Heimnetz" - "Netzwerkeinstellungen": enable option "Zugriff für Anwendungen zulassen" (enabled by default)

I have "allow access for applications" enabled.
My config node looks like this:

This should be correct (only thing I'm not sure about is the 49000, but I didn't change that). I think the connection is working, otherwise it wouldn't have said 'Services received', would it?

What version fritz-os do you have?
In version 7.25 Fritz changed some things regarding login for apps.

I've got Version 7.21 and the system tells me that it's up to date. So that shouldn't be the cause of the problem either (after all, the node ran on the older versions...)?
Rebooting the Raspi didn't help either.

Another screenshot, maybe it gives you another idea?

-I just reinstalled the nodes, no difference.

  • Then I entered a wrong password on purpose --> I get the same message "Services received" - so that doesn't seem to mean anything. Maybe it's the 49000 <-- this is the port, i guess. Is there a way to see if it's the right one or change it in the fritzbox to 49000? That might work, I have no other ideas at the moment...

Edit 2:

  • I tried a few of the other nodes (due to a lack of information without really knowing what I was doing...). Maybe this gives anybody a hint of where the problem is?

Try this in a browser to see if there's output.


That's what I get:

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.