Node Properties Not Displaying in Editor

#1

I created a custom node that has HTML properties that should display in the Node Properties Editor window. None of them are displayed.

Here is my .HTML file

<script type="text/javascript">
    RED.nodes.registerType('ss-modify-points-value',{
        category: 'Emerson',
        color: '#a6bbcf',
        defaults: {
            name: {value:""},
			applicationHash: {value:""},
			applicationPointHash: {value:""},
			applicationPointName: {value:""},
			applicationValue:{value:""}
        },
        inputs:1,
        outputs:1,
        icon: "file.png",
        label: function() {
            return this.name||"ss-modify-points-value";
        }
    });
</script>

<script type="text/x-red" data-template-name="ss-modify-points-values">
    <div class="form-row">
        <label for="node-input-name"><i class="icon-tag"></i> Name</label>
        <input type="text" id="node-input-name" placeholder="Name">
    </div>
	<div class="form-row">
        <label for="node-input-applicationHash"><i class="icon-tag"></i> Application Hash</label>
        <input type="text" id="node-input-applicationHash" placeholder="applicationHash">
    </div>
	<div class="form-row">
        <label for="node-input-applicationPointHash"><i class="icon-tag"></i> Application Point Hash</label>
        <input type="text" id="node-input-applicationPointHash" placeholder="applicationPointHash">
    </div>
	<div class="form-row">
        <label for="node-input-applicationPointName"><i class="icon-tag"></i> Application Point Name</label>
        <input type="text" id="node-input-applicationPointName" placeholder="applicationPointName">
    </div>
	<div class="form-row">
        <label for="node-input-applicationValue"><i class="icon-tag"></i> Application Value</label>
        <input type="text" id="node-input-applicationValue" placeholder="applicationValue">
    </div>
</script>

<script type="text/x-red" data-help-name="ss-modify-points-value">
    <p>A node for setting a new  Point Value for an Application</p>
</script>
0 Likes

#2

you have data-template-name="ss-modify-points-values" instead of data-template-name="ss-modify-points-value"

0 Likes

#3

Thanks... Looking at code too long and can't see any more.... Time for a break
That fixed the issue.... Much thanks!!!

0 Likes

#4

you're welcome.

I like to use an editor with "intelligent" auto complete like atom or visual studio code. Helps somehow to prevent these bugs

0 Likes