Node-RED 0.18.5 released

#1

We have just published a new maintenance release - https://github.com/node-red/node-red/releases/tag/0.18.5

Some particular highlights:

  • if you have Projects enabled, the welcome screen now lets you clone an existing project rather than force you to create a blank project before you’re able to clone one
  • the Switch node has a new rule for checking the type of a message property
  • the Function node now supports node.debug() and node.trace() for logging messages at those levels
  • The MQTT Broker config node lets you set a Disconnect message - this is a message the client will send before it cleanly disconnects from the broker. This is distinct from the Will message that the broker sends if the client disconnects unexpectedly.

Plus lots of fixes and tweaks - thanks to all that reported issues and provided pull-requests along the way.

7 Likes
#2

Just updated Node-Red. Two times actually, since my npm says it installed 0.18.5 but the Node-Red admin info still mentions the version being 0.18.4. Is this a bug or something on my side?

#3

I’ve updated 4 Pi systems and 1 Windows one - all say 0.18.5 in Node-RED menu
I did do a browser refresh after each install

#4

How did you do the update and did you restart Node-RED?

#5

I ran the following command, and after that I ran sudo pm2 restart node-red:

<username>@<ip>:~$ sudo npm install -g --unsafe-perm node-red
[sudo] password for <username>:
npm WARN deprecated bcrypt@1.0.3: bcrypt < v2.0.0 is susceptible to bcrypt wrap-around bug. Upgrade to bcrypt >= v2.0.0 for improved support for newer bcrypt hashes
npm WARN deprecated i18next-client@1.10.3: you can use npm install i18next from version 2.0.0
npm WARN deprecated mailparser@0.6.2: This project is unmaintained
npm WARN deprecated nodemailer@1.11.0: All versions below 4.0.1 of Nodemailer are deprecated. See https://nodemailer.com/status/
npm WARN deprecated mimelib@0.3.1: This project is unmaintained
npm WARN deprecated mailcomposer@2.1.0: This project is unmaintained
npm WARN deprecated buildmail@2.0.0: This project is unmaintained
/usr/local/bin/node-red -> /usr/local/lib/node_modules/node-red/red.js
/usr/local/bin/node-red-pi -> /usr/local/lib/node_modules/node-red/bin/node-red-pi
+ node-red@0.18.5
updated 3 packages in 5.941s
#6

I’ve just discovered that running the plain node-red command will start up version 0.18.5, while the pm2 command will start the older 0.18.4 version.

Global Node-Red is 0.18.5.

npm list -g node-red
/usr/local/lib
└── node-red@0.18.5

Local Node-Red does not exist:

 npm list node-red
/home/user
└── (empty)

How can it still start 0.18.4 through pm2 I wonder…

#7

Sounds like you’ve mixed up some versions. Perhaps you have a local install as well as a global one?

Check out the config for PM2 to see what it runs then get rid of it.

#8

Turns out I had installs in /usr/bin/node-red and also /usr/local/bin/node-red.

PM2 was still looking at the old environment. Running pm2 unstartup got rid of the old startup service after which I could program in the new service.

Thanks!

#9

If any PM2 user feels the urge to offer edits/updates to the docs please do so ! Thanks

1 Like
#10

I only use it on Windows I’m afraid. I use a custom install on my Pi.

closed #12