Node-RED 0.20.0 Released


#41

Thank you Steampunk_prof. Downgrading to 0.19.6 current grabbled text issue for myself as well.

Kevin - will continue to monitor forum post and will move back to 0.20.0 when I see announcement of rectification of this issue. Also always happy to upgrade and test should it be helpful.


#42

Not sure what;s going on as I installed a node and it broke it again, so back on a repeat of the exercise. I wonder if something has got a bit broken :slight_smile:


#43

Small point, I'm not Kevin.

Thanks for keeping an eye on it. It's a very weird error.


#44

The usual fix for this is to remove usr/bin/node and usr/lib/node_modules and run the script again.


#45

Thank you for the successful update!
Since v0.20 node-red (I use the docker version) appears automatically in my browser in german (my regular browser setting).
I would like to have node-red in English again. Is there any way to adjust this?


#46

Had another go, cleared the cache on Firefox, got rid of /usr/bin/node and /usr/lib/node_modules
and the function edit window is garbled again on just this one Pi.


#47

do you have similar errors in your browser console/developer tools, to those reported by @zenofmud above ?


#48

Yes I do get them.


#49

@dceejay if there is anything you want me to try or debugging you want to see, let me know. For the moment I'm back on 0.19.6 but I've flipped it back and forth a couple times already.


#50

In case it is useful. I'm running 0.20 on Windows 10 having upgraded from beta (several beta's in fact) and all is well here - no problems with ACE either - I'd have certainly noticed that since I'm using it extensively for uibuilder v2.

13 Mar 22:22:11 - [info] Node-RED version: v0.20.0
13 Mar 22:22:11 - [info] Node.js  version: v10.15.1
13 Mar 22:22:11 - [info] Windows_NT 10.0.17763 x64 LE

Projects currently turned on but it was the same without projects too.


#51

Syncing my project with GitHub is broken...

I'm on Win10 and I used NR 0.20 to do the initial cloning of my rep from GitHub without issue.

After I committed a local change, the Push runs this:
2019-03-14T23:29:18.699Z git -c credential.helper= push origin HEAD:master --porcelain

but it gets stuck here"
[err] error: cannot spawn c:\Users\... ....\node-red-ask-pass-sh: No error

that file contains:
"$NODE_RED_GIT_NODE_PATH" "$NODE_RED_GIT_ASKPASS_PATH" "$NODE_RED_GIT_SOCK_PATH" $@

Anyone else having this issue? I've tried it on both Edge and Firefox browsers.


#52

@SmokeyRider. This issue has been discussed here. Did you manage to sync with GIthub in previous versions of Node-RED ?


#53

No, I'm new to NR. but that command does work from powershell


#54

if it helps, here's the error I'm seeing in the firefox debugger:


#55

We still have an outstanding issue being able to access remote git repos on Windows 10.

If you are familiar with git, you can run the commands manually in ~/.node-red/projects/<name-of-project> in your PowerShell.


#56

As an experiment, just happening to have another mac that has never had Node-RED installed on it, I installed it and I do not see the squished text problem and nothing shows up in the browser's JavaScript console.

machine with the issue:
Mac mini (Late 2012)
macOS 10.13.6
Node-RED v 0.20.0
node.js v 10.15.1

machine without the issue:
Mac mini (Mid 2011)
macOS 10.13.6
Node-RED v 0.20.0
node.js v 10.14.1


#57

Hi @zenofmud

on each of those machines, can you do the following?

  1. Find the node-red install directory, and the editor code under it:

    If you installed it as a global module, run
    npm list -g --depth 0 node-red

    That will give you output like:

    /Users/nol/.nvm/versions/node/v8.14.0/lib
    └── node-red@0.20.0
    

    Under that same directory should be:
    node_modules/@node-red/editor-client/public

  2. Once you have found that public directory, run the following command from that directory:

    find . -type f -exec md5 "{}" + > /tmp/nr-checksums.txt
    

    That will generate a list of checksums for all the files.

  3. Once you have that file for each machine, you can compare all the checksums to see if any local file corruption has occurred - alternatively, send me (nick.oleary@gmail.com) the files and I can take a look.

This will help rule out some sort of local file corruption on the bad machine.


#58

@knolleary when I run the find nothing returns (same on both machines)

Downdeep:~ paul$ cd $HOME
Downdeep:~ paul$ cd /usr/local/lib/node_modules/node-red
Downdeep:node-red paul$ npm list -g --depth 0 node-red
/usr/local/lib
└── node-red@0.20.0 

Downdeep:node-red paul$ cd node_modules/@node-red/editor-client/public
Downdeep:public paul$ ls
favicon.ico	red		vendor
Downdeep:public paul$ find . -type f -exec md5 "{}" + > /tmp/nr-checksums.txt
Downdeep:public paul$```

I'll be out for the next 2 1/5 hours

#59

Sorry, should have been more explicit. The command is writing its output to the file /tmp/nr-checksums.txt - that's what you need to look at.


#60

Had a minute to do this before I dash - the files are the same. (used BBEdit copied the output of each into a window and had BBedit co a compare and they are the same - to see it it would make a difference, I upgraded node.js to v10.15.3 so both machines would match.