🎉 Node-RED 3.0.0-beta.3 released

:tada: The third and final beta release of Node-RED 3.0 is now available.

Node-RED 3.x requires at least Node 14.x or later. We recommend the current Active LTS release, Node 16.x.

This release brings some fixes and improvements to the new Junction feature based on your feedback from the first beta - as well as one major new feature that should make things easier in the editor...

If you haven't already, please read through the release notes for beta.1 and beta.2.

Here are the highlights for this release.

The Change Log has the full list of changes.

Note: if any issues are reported against the beta, we'll update this post to list them here. If you hit a problem, please do check back here before adding a comment.

Known Issues

  • none

Right-Click Menu

We have (finally) added a right-click context menu in the workspace.

This gives you quick access to a lot of built-in actions in the editor and should help users discover more of the features available.

Getting the list of options right in the menu has been a non-trivial task - trying to get the balance right of how much we add versus making it too long and hard to find. I'm sure everyone will have a different opinion on what should (and shouldn't) be included. I'm sure many of you will let us know :slight_smile:

There is a possible future enhancement to add something like a 'favourites' section - which allows you to add your favourite/most used actions to the menu for ease of use... so keep that in mind before asking for everything to be added.

File Nodes configuration

Following feedback from the last beta, we've updated the File nodes to be a bit more intuitive in their configuration. In the last beta they let you set the filename, or specify a msg property - but the filename option was labelled str as it was expecting a string. We've made the tweak to label this as path which is more useful to the user.

Installing the beta

If you want to try out the beta, you will need specify node-red@next when you use npm to update. Without the @next you'll still get 2.2.x

So on a Pi you'd do:

sudo npm install -g --unsafe-perm node-red@next

Reporting problems

If you hit any problems, please report them either as a reply on this topic, or in the #core-dev slack channel. Please do not post new topics to the forum regarding the beta as that could confuse users who are not using the beta.

Outstanding work

As we've said with the last two betas, this contains just about everything for the final release - but this time we mean it even more.

There are a couple PRs that'll get sorted early next week, and then we'll hopefully get 3.0 released in the next two weeks.



What us? Surely not :grinning:

That was going to be my suggestion anyway - for a future release of course.

If there were an advanced option to allow any available action to be added, that would be even better.

Thanks again Nick for all the work that goes into this, I know it isn't easy.

So first thing I did was right-click :slight_smile:

but was surprised that the Insert->Junction was greyed out

So I added a little flow but when I right clicked - still greyed out

Select one or more wires first - the junction will get inserted into them.

ok... not what I was expecting but ok :slight_smile:
But then I tried it
and as soon as I right-clicked, the wire stopped being highlighted

and so still no option :frowning:

Interesting... Did you click on the wire itself? If so, try right clicking off the wire.

Yes but off-wire still the same

I'm seeing the same behaviour Si, clicking on or off the wire - still the same result.

Should this work?


Node v14.19.3

Yes, but you can see the selection is being deselected when the menu opens... So any subsequent action had nothing to operate on.

This was definitely working in the branch for this code... Will investigate.

1 Like

Installing beta.3 with the install script generates (on my Pi) the following deprecation warning. Should be easy to fix...

Same in chrome on widows.

However, if you have a context menu key on your keyboard, the selection is not lost - suggesting the mouse down is not being filtered for button 2 perhaps?

Thanks for that. I suppose the script is going to have to either suppress that message or test the NPM version and switch from --global to --location=global for NPM v8+

Issue raised for tracking: NPM v8 has depreciated `--global` · Issue #30 · node-red/linux-installers · GitHub

Not the same in Chrome on Mac - it is working as intended for me here... Sigh. Just as IE11 is put out of our misery...

1 Like

So much for npm following standards. They removed a major feature which causes things to break in a minor release.

If I press control + left click on a Mac, this happens

Not happening on windows - bah!

Is that from the blank canvas or did you do something first?

It isn't removed, just deprecated. Nothing has been broken.

Blank canvas

SORTED - Browser caching caused problem
Ctr click on Windows (Chrome) works but blanks out the workspace until a selection is made, which never happened in previous beta.



It isn't even deprecated ... anymore ... currently.
Thus I'd propose a "won't fix" - yet anticipating that people will complain/report from time to time.