Node-Red and tp-link 4G+ router

Does anyone have any clues how to interact with the tp-link mr600 4G router?

I have managed to get it to send SMS messages via a shell script wrapper for the node.js code at b. It's very inelegant.

The router does support SNMP but I have no idea how to use SNMP to obtain info such as daily bandwidth, download speed etc. which would be useful to have in Node-Red.

Any suggestions would be very welcome!

Have you configured the SNMP settings first under System Tools?

A good write up on SNMP here. What is SNMP? Basic Tutorial on NMS, MIBs, OIDs, Traps & Agents - PC & Network Downloads -

SNMP will give you data about the router and its performance but won't give you much control over it.

Personally, I find that it is easier to use Telegram and InfluxDB (and MQTT output too) to capture SNMP information, You will need some information about the SNMP configuration for the router. This is typically embodied in a MIB file Management Information Base.

There is an snmp node as well but some SNMP values are quite complex to decode.

90% of the tplink routers can be flashed (or come with) openwrt out of the box - have a search for control of that - it has the LUA language built in and is pretty open.


In fact here you go - @dceejay has even put together a version of NR that runs on them - will be dependant on how much free ram etc you have with the unit

Or an alternative - mqtt on the Openwrt box

and last but not least


Note: that version of Node-RED was based on a prebuilt nodejs v8 which is no longer supported. I haven’t had time to look to find a version of node v12 and rebuild Node-RED on that. (Basically I wouldn’t recommend using it at the moment)

Thanks for all the suggestions and links.
I think the router can be flashed with Open WRT. At least there is a mention in the manual "This will invalidate the warranty". I may go that way but not while it's still new...

I think I have configured SNMP on the router, at least it's enabled.
There doesn't seem to be an MIB available anywhere. Requests for one on tp-link's support forum are ignored.
If I run snmpwalk -v 2c -c public I get a long list of stuff like this

I'm guessing that the "iso.3.6...." is the OID, which Node-Red's SMTP nodes require me to specify.
And I guess that an MIB would translate these codes to something meaningful.

I clearly need to do some more reading!

1 Like

Yes, that is correct.

However, a lot of entries are standard and TP-Link do support some SNMP publicly:

Oh, good find, thanks!

I found this inventory of MIB files collected by a French IT consultant. MIBs Corner>All MIBs>Letter T could be of some use? I am looking to flash one of my MR600's with OpenWRT for other reasons, I might try over the weekend [EDIT] maybe not, it seems there's no support for either V1 or V2.

@jbudd I requested all relevant MIB info for this router from a technical contact I have within TP-Link, they have now sent me a file with a statement that only Public MIBs are supported. If you wish to receive it please PM me.

1 Like

Thanks @smithy, that would be very welcome. I have tried to PM you, not sure if it was sent

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.