Node-red and z-wave for dummies

Can you check the config, and instead of using /dev/ttyUSB0, determine the serial number of the device:

cd /dev/serial/by-id
ls -l 

You will find the device there

use the full path in the config node port field, example;
/dev/serial/by-id/usb-0658_0200-if00

Once you deploy, check the logfile again (copy/paste the text here, not screenshot).

@Dom, check in your personal messages if you have a message from a bot called discobot, follow the instructions and you get more privileges (not sure about the limit because you are new, at least you get to learn the forum ;))

@Dom - this is caused because you used incorrect USB device. follow the steps i described.

1 Like

Maybe this advice is too early in the process but remember that devices already included in the "old" controller network needs to be excluded from that zwave network BEFORE it can be included in the new controlled by the Aeon stick

1 Like

Hi krambriw.

you are right, indeed.
The problem is that my old server (VERA 3) is dead, and I just try to build an alternative, using OpenSource (eventually with proprietary addons).

Thus, all my devices were still "connected" to my Vera, but I "hard or factory" reset all of them.

Btw, I really don't know if, splitting controllers from the frontend is really a good solution.

I have HomeAssistant, but .. not sexy at all, and quite indigest to configure.
Jeedom is a little bit more sexy, but you have to pay for every addon, without any possibility to test them before.
I also tried Domoticz, but ...

Finally, I'm lost ... and I do not know which solution to choose and configure :cry:
I need a reliable solution

I have device of type :

  • ZWAVE
  • Bluetooth / BLE
  • rfxcom 433
  • Wifi
  • BLE beacon
  • enOcean devices ... (because they do not require any power supply)

I need something able to manage everything in a very simple way.

Reason why I try to configure node-red and MQTT as source for any homeassistant application :slight_smile:

Kr,
Dom

@bakman2

I'm still not able to use my device :cry:

AEOTEC stick seems to have problems on Rb PI4 USB configuration, as both are respecting their own ... standard :frowning:
The suggested solution is to connect the stick via a USB 2.0 hub, which I did.

But ... still not able to go further :frowning:

Thanks
Dom

@Dom

I can only give you my experience and what I did at the end. I tried a lot making NR and zwave nodes work maybe 2 years ago. Most of the time, I failed, sometimes I could eventually see it worked but I could never make secure devices work. That said, it might be possible I would succeed today if I would use more recent versions of everything. Instead, at that time, I decided to use Home Assistant (HA) and it's built in support for z-wave, including my Aeotec Z-Stick Gen5. To communicate between NR and HA I use mqtt . It is still working fine. HA also supported secure devices without problems. I have since then decided to keep it as is.

In general terms, I'm not that happy with z-wave; is too complicated to setup, is too complicated to move to another network and is by far too expensive. I have instead migrated to Shelly but have some few z-wave devices and HA still in operation. I'm running HA in a dedicated RPI3 but I don't know if that is really required if you have enough room available in a common NR+HA setup

You are complicating things for yourself.

When you connect the Aeotec via an usb hub and type lsusb do you see the device ?
If yes, it is working.

Determine the serialnumber as suggested above and use that as the device address. (the reason why you want to do this: when you plugin the stick into another port, it uses a different device file, using the serial, it will determine the correct port).

Then we can move on the next step.

Note: Above you add a zwave-out node with addNode() - as stated above: the out-node only produces output messages based on event changes.
Everything that needs to be controlled, has to be done via the zwave-in node. zwave out is used for listening only.

@bakman2

you are indeed 100% right, but I need to gain full control of my box.

On my Rb pi4 dédicated to HA, I also have USB stick for ZWAVE :slight_smile:
It automatically detected one of my zwave devices, but refuses to detect any other one.
Even after a factory reset of the device.

Reason why I built a second Raspberry, dedicated to node-red and MQTT, on which I connected my RFXcom and my AEOTEC controller (it is known to not be compatible with rb pi 4 as Raspberry does not respect the USB standards !

Thus I have 2 z-wave controllers, and any of both are able to add devices.

This means I mis-configured something or I do not follow the correct way to add devices (but I was not able to find human readable documentation for that).

Thank you for yoour patience :slight_smile:

pi@raspberrypi:~ $ lsusb -t
/:  Bus 02.Port 1: Dev 1, Class=root_hub, Driver=xhci_hcd/4p, 5000M
/:  Bus 01.Port 1: Dev 1, Class=root_hub, Driver=xhci_hcd/1p, 480M
    |__ Port 1: Dev 2, If 0, Class=Hub, Driver=hub/4p, 480M
        |__ Port 2: Dev 3, If 0, Class=Vendor Specific Class, Driver=ftdi_sio, 12M
        |__ Port 3: Dev 4, If 0, Class=Hub, Driver=hub/4p, 480M
pi@raspberrypi:~ $ lsusb
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 004: ID 14cd:8601 Super Top 4-Port hub
Bus 001 Device 003: ID 0403:6015 Future Technology Devices International, Ltd Bridge(I2C/SPI/UART/FIFO)
Bus 001 Device 002: ID 2109:3431 VIA Labs, Inc. Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.