Node-red arduino

*.ino in Arduino is working well
The flow for noder-red is ok
There is a communication error with /dev/ttyAMA0 Permission denied.

Is there someone with a solution for that permission denied.

on the command line type in the following:

$ ls /dev/ttyACM0  -l

On my system I get

crw-rw----+ 1 root dialout 166, 0 May 17 21:51 /dev/ttyACM0

Add the current user to the dialout group:

sudo adduser current_user dialout

so on a Raspberry Pi (If you chave not changed the default user)

sudo adduser pi dialout

You can find out the current user with



I tried this help

ls /dev/ttyAMA0 -l

crw -rw-rw- 1 root dialout 204 64 mei 18 15:30 /dev/ttyAMA0

pi is already member of dialout

Whoami Ă  pi

And the result is negative


Verzonden vanuit Mail voor Windows 10

Can you post the output of:

ls /dev/ttyA*


The output is


Hope you can help me with this problem


Verzonden vanuit Mail voor Windows 10

If pi is already a member of the group dialout I have no idea why access to the serial port is denied. Which version of Node-red are you using?

This is the Bluetooth port on the Pi!! I think you might be using the wrong serial port if you have a wired connection!

Have a look at this how to setup the port correct:

1 Like

Ghany thanks again.

Indeed i have a wired connection

ls /dev/tty* gives the possibility to use dev/ttyS0

I tried /dev/ttyS0 and the error “permission denied “has disapeared .

But now is there a new error:

"serial port /dev/ttyS0 error: Error: Error: No such file or directory, cannot open /dev/ttyS0

Now i am looking for that solution.


Verzonden vanuit Mail voor Windows 10

Edje thanks

In deed i use the wrong port

I wiil try to read and understand your message


Verzonden vanuit Mail voor Windows 10

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.