Raspberry Pi 3 B+June Raspbian Serial Port Node-RED


#1

After a terrible couple of days updating Node and Node-Red - all working thanks to DJ... the serial port on the PI3 is not having it. I've turned off console use of serial, disabled BT and Pi user is part of the relevant group but I STILL cant send a simple string to serial (either ama0 or S0) - permissions.... I even simply changed permissions - - there HAS to be a way to do this.. as far as I can tell, the NR serial port node is fine.


#2

Can't get it to work either


#3

Is this another case? Serial port will not work with cable already plugged in


#4

I remember when I tested my greenhouse system on the Pi3 (using an SD card from a Pi2) that I was getting rubbish from the serial attached radios (Pi in the house controlling an Arduino in the greenhouse)/ I movedc platform after that to Omega Onion + Arduino expansion. I've since moved house and have no greenhouse.


#5

No, not using USB serial. There is also an issue with some USB-Serial chips on Arduinos that aren't recognised on boot.


#6

@scargill Are you getting an error shown anywhere (node-red-log, syslog ...)?


#7

Have you tried from a console terminal?


#8

Sorry - my error. Had to remove bluetooth - then it worked. Their second serial connection is no good so Bluetooth had to go to get serial. They dont make it easy.


#9

No they don't.

Nice to see you back and around by the way, hope you are keeping well?