"node-red-contrib-cip-ethernet-ip" is crashing node-red

Some background on what I am trying to accomplish. My company is a manufacturing facility, that has automated manufacturing lines. I have used node-red in the past for various projects, for example creating data streams form MQTT to Influx, as well as storing data into google drive and an sql database.

Currently I am trying to send Machine Status to a smartwatch/smartphone using the ethernet-IP node and telegram node. I'm sending data from a allen-bradley plc to telegram application on my smartphone.

This is the basic look of the flow:

After set-up and deploying the flow, everything will work fine for awhile and then node-Red will crash and I have to then uninstall everything and reinstall.

I have ran node-red using injects, instead of the Ethernet-IP node and this functions great.

Once the Ethernet-IP node is hooked back in the flow it will work for an hour and the crash.
Below is the error:

I have tried with all data types, it does not matter if its Boolean, Int, Dint or Real.
I am running node-red on my windows 10 machine if anyone is wondering.
If anyone has any information on this node this would help out a lot.

Here is what's in the function node if anyone is wondering.


You say it "crashes" node-red but as far as I can see (from your screenshots) node-red is still running.

I guess you mean the connection to PLC does not recover?

Have you tried simply stopping / starting node-red? or modify something in the EIP node & deploy (so it is stopped/started)?

In any case, you should report this as an issue on the nodes repository here: Issues · st-one-io/node-red-contrib-cip-ethernet-ip · GitHub

Once node red is installed and started, i configure my flow to the one shown above. Everything runs great for a few hours and then i get the error shown, like it stops communicating. Once this error is thrown on node red, Node-red completely crashes and I can not get back to my flows. The only way to get back in to the node-Red interface is to uninstall node red and reinstall.

Yes, I have tried starting and stopping, but once this error happens you can not do anything with it.

Thanks for the information, I will report it.

That is really not necessary (just a really really long and OTT work around)

Can you show the logs from node-red starting to node-red stopping & again after trying to restart?
(PS, copy the log as text not screenshot)

It seems my issue happened to be a timing issue between the plc and the windows machine. I changed the plc from continuous 500ms to periodic 10ms and then changed cycle time on ethernet IP node to 2000 ms. This seems to have worked for now.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.