Node-red-contrib-generic-ble No BLE devices show up on scan

Hi,

I am running node-red on macOS. I am new to node-red and simply want to read BLE sensor data from a peripheral (TI LPSTK-CC1352R) on my macbook.

I am using the node-red-contrib-generic-ble 4.0.3, it installs fine (Screenshot below), I follow the instructions at node-red-contrib-generic-ble (node) - Node-RED for configuring the 'Generic BLE Out' node.

Here's the issue. On enabling 'BLE Scanning' nothing shows up ! My terminal window does say '[info] [GenericBLE] Start BLE scanning' (Screenshot below) but no peripheral device comes up in the drop-down menu. The BLE sensor node is working. I verified by finding it on the Bluetooth app (LightBlue) so sensor is transmitting.

Could someone kindly point how to solve this issue ? Thanks.

I have checked that both the Terminal and Web Browser have the permission to use Bluetooth in the security and privacy setting of the laptop.

did you restart NR after installing the node?
what version of macOS are you running?
have you tried any of the other bluetooth nodes?

You may want to open an issue on the node's github page.

Hi. Thanks for the reply. Yes restarted NR, also restarted laptop bluetooth after installation but to no avail. I am running on macOS Monterey 12.1, I tried node-red-contrib-noble-bluetooth also, scanner node updates to "Scanning" on injecting "start" but nothing shows up on debug/msg.

Hmmm, I can’t install the node on my Mac mini m1 I think I need Xcode, but it won’t install eithor.

Ok, I've got it installed BUT...I have nothing to test it on (hmmm I wonder if my bluetooth keyboard will work?)

Did you see any error in the log when you installed it? If not please do this.

  1. remove the node from any flow using it.
  2. uninstall the node
  3. stop node-red
  4. open a terminal window
  5. enter cd .node-red
  6. enter npm install node-red-contrib-generic-ble
    copy everything from that command to when it finishes and paste it to a reply.

Also if you do a forum search using Node-red-contrib-generic-ble you will find a number of threads with problems with this node. As I said before you should open a issue with the author of the node on GitHub.

Thanks for your reply. No I actually used the GUI (Manage Pallette) option to install the generic-ble.
Anyway I followed your steps above, here's the screenshot, anything that stands out ?
Screen Shot 2022-04-21 at 7.13.22 PM

Yes, I have Xcode installed already