Node-red-contrib-homekit-bridged (NRCHKB)

I am looking for a reliable interface to HomeKit to replace my Homebridge solution for home automation. I want to maintain Alexa and Siri/Homekit user interfaces in the transition.

I have a pi 4 with Node-Red v3.0.2 running. The Node-Red flow paradigm and sleek interface seems great and hope it offers a decent Apple solution.

Functionally, node-red-contrib-homekit-bridged seems like a possible option. It was recommended in this forum and seems alive with a code rev only 6mo ago.

I ran the install without error using the palette manager. Node-Red thinks these are installed:

I then installed the simplest-looking example, a "Switch", and it presents an error "unknown: homekit-service".

I uninstalled the package and reinstalled it and get the same problem.

I'm open to any recommendations on fixing this install issue or other nodes to try.

Note: I attempted to contacted the developer using the "Discord" invitation they provide, but that was a dead-end (the invitation is not valid on the Discord system). Maybe this node's development is dead?

As you already stated, your installation seems to have an issue.
That's how it looks like on my system:

Do you spot the difference regarding the homekit-service node?

You should check the Node-RED log output generated during the installation of this kit. Perhaps there's an indication of an error.
Could it be that you've another node (from another package) already installed named as well homekit-service ? When you install by the pallet, that's not possible. Node-RED shows a conflict warning and disables the button in case it discovers same node-types.

I have never found the homekit-bridged node to be reliable. It uses its own hap server (just like homebridge does). If you restart node-red, it will cause state restarts for those homekit devices too. I have not tried it recently though. I use homebridge - which is solid - and control devices with node-red-contrib-homebridge-automation, which works reliably (here).

I see the difference. The homekit-service is orange for your installation and grey for mine. Not how errors should be captured, though! Obviously, something failed during installation and node-red didn’t notice or care enough to inform me.

I can try to figure out where the installation logs are this weekend (traveling now) and have a look. There was a “view log” button shown for about 5 seconds during the installation but I didn’t find a gui log viewer afterwards.

I was thinking that node-red would be my hardware interface and central status and logic store.

I was hoping that there are nodes that allow for upstream interfaces to HomeKit, Alexa (even Google Assistant) for user interfaces (device triggers and status presentation).

The Alexa nodes look solid for voice control. For the UI, maybe I will use the node-red ui and the Alexa app and just toss out Apple iOS Control Center. Sometimes the easier and cheaper path makes sense!

I happen to be very close friends with the team on discord - I can assure you, we are extremely active on discord, neither is the project dead, likely just a link that needs updating.

Never the less, I'll call on one of the servers admins : @crxporter or @Shaquu, can you provide a link to a valid discord link or help out here?

Here is an invitation : Discord

For indexing sakes, let's recategorise this post - Done! :imp:

1 Like

Hello :slight_smile:

Hey there. Thanks for the attention on getting the node’s developer channel open.

I did try to use the new Discord link that you provided above, but I still receive an error, so cannot communicate with them yet:

If the Discord team can help out, then I’m sure the developers would appreciate hearing issues raised by their users.

It is very strange. I tried link and works for me.
Send me your name on private, I will invite you!

I cannot figure out how to send a private message in this forum and if I log on to, it said I need to “friend” someone to send a direct message. I tried to friend you but get this error:

Sent on private message

Here are the log items for the installation - no errors there. I will come back here to let folks know what the node's dev team suggests after Shaquu kindly connects us.

17 May 16:25:20 - [info] Installed module: node-red-contrib-homekit-bridged
17 May 16:25:22 - [info] Added node types:
17 May 16:25:22 - [info]  - node-red-contrib-homekit-bridged:nrchkb
17 May 16:25:22 - [info]  - node-red-contrib-homekit-bridged:homekit-bridge
17 May 16:25:22 - [info]  - node-red-contrib-homekit-bridged:homekit-standalone
17 May 16:25:22 - [info]  - node-red-contrib-homekit-bridged:homekit-service
17 May 16:25:22 - [info]  - node-red-contrib-homekit-bridged:homekit-service2
17 May 16:25:22 - [info]  - node-red-contrib-homekit-bridged:homekit-status

As promised...

The Discord link on the node page's footer was fixed and I got through to the dev team (thanks Shaquu!).

The dev team suspected a node type conflict existed and was causing this fatal error. The solution was a node-red restart which worked to solve this issue.

I am new to using node-red, so I am not sure if these types of "collisions" are common. If they were, then we would certainly want some alerting or automated resolution for this type of problem.

For now, resolution will start with a restart!

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.