Node-red-contrib-modbus installation failed

node --version v16.17.1
npm --version 8.15.0

node-red-contrib-modbus installation issue.
I have installed the mentioned modbus package on my local machine and it worked perfectly. But when try to install the same package on windows virtual machine its showing an error.
Seems like virtual machine doesn't have a python package in windows build tool.

Thanks for any help!

So install python in the VM :wink:

However, are you sure you have installed the "necessary tools"?

When you installed NODEJS, was the checkbox to include "necessary tools" set?


Thanks for the reply.
i have uninstalled nodejs and installed with necessary tools. Still its showing an error but slightly different.

Do you know what exactly has to be installed from python?

Nothing. Python is used to compile the C bindings for the serial port.

NOTE: since this is a VM, does the VM have access to serial ports? (check device manager)

Did you restart the VM after re-installing nodejs (the system path is applied upon restart)

Also (after restarting VM), inside the VM in a terminal, what does where python show?

Hi Steve,

Thanks for the support.
I have installed python and restarted but still there is an error; seems like VM doesnt have the access to serial port.
VM doesnt has serial port by default; can you explain how to give access to serial port?
Attached the latest log fron node-red, device manager settings


That will depend on many things (VM setup, hypervisor used, guest OS, etc etc etc). Not really a question for this forum. Google is your friend.

Also, looks like your VM has cert errors or cannot download from

Question: Must this be a VM? If you want hardware access, better off running on the machine instead of a VM.

Even after setting setting up the ports on windows VM, its showing an error.
Seems like i need linux based or a physical machine.

Will be great if you can look at the log file for last time. let me know if you have any idea.
Thanks anyway.

As I said before

This might work if you run ubuntu in a VM - or use docker. BUT - whay are you using a VM and why are you using windows in the VM? (curious)


Please dont post pictures - they cannot be searched (by future readers with similar issues) and they are hard to read - PLEASE post as text - and - In order to make code readable and usable it is necessary to surround your code with three backticks (also known as a left quote or backquote ```)

   code goes here 

See this post for more details - How to share code or flow json

Hello Steve,

It was VM cert issue.
Solved :slight_smile:

For your your question why i am using VM windows.. Just want to try :slight_smile: and not familiar with other OS.

Now is a good time to change that :slight_smile:

1 Like

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.