Node-RED-Contrib-OPCUA server not running

Hi All,
I have a Node-RED application developed on a Win10 system where node-red-contrib-opcua (v0.2.257) nodes are used to create an OPCUA server using OPCUA-Server node.
Since the beginning of the application development, I saw that the opcua server node "has an own life", not directly connected to the entire flow where it is inclued, as it has some internal "services" that are automatically run as soos as the node-red and related flow are started (you can see "status" changed even if the node is not executed by the flow).
Anyway, going to the point, sometimes, when Windows is running from power up, opcua server is not running properly with obvious consequences on the entire application (it seems that some internal node services "are not launched" properly).
Also the status node linked to the opcua server node included in the application is not updated corretcly at flow startup when the error occours, to confirm that the node has some trouble.
The error is occurred only twice on more than 50 application installations done.
Please let me know what you think about it.
Thank you.

Take a look what is printed to console, it could give some hint what is going on...

Hi mikakaraila
on the console a warning message says to download "openssl.exe"...
Quite strange that this request happens a lot of time after the application installation, because, as I have already said, the application has been installed a lot of times and only in 2 cases this error happened.
Please let me know.
Thank you

It is coming from the node-opcua-crypto package. Certificate manager uses it.
If you want to report it go that package github...

Sincerely, I don't want...and I was not "informed" about this option.
Can you explain me how to disable that option?
Thank you

It is by default embedded, otherwise you must manually create server certificate and import each client certificate and trust them. Certificate manager automates everything behind.

And only option to generate certificates by your own is to use openssl :slight_smile:

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.