Node-red-contrib-usb installation not possible

Hello,

I´m trying to install the package "node-red-contrib-usb", but it aported with error.

2021-01-14T10:25:04.862Z npm install --no-audit --no-update-notifier --save --save-prefix="~" --production node-red-contrib-usb@1.0.0
2021-01-14T10:25:51.877Z [err] npm
2021-01-14T10:25:51.878Z [err]  
2021-01-14T10:25:51.878Z [err] WARN registry
2021-01-14T10:25:51.878Z [err]  Unexpected warning for https://registry.npmjs.org/: Miscellaneous Warning EHOSTUNREACH: request to https://registry.npmjs.org/node-red-contrib-usb failed, reason: connect EHOSTUNREACH 104.16.18.35:443
2021-01-14T10:25:51.880Z [err] npm
2021-01-14T10:25:51.880Z [err]  WARN
2021-01-14T10:25:51.880Z [err]  registry Using stale data from https://registry.npmjs.org/ due to a request error during revalidation.

Does anybody know a soution for this?
Node red runs on a revolution pi

That is saying that the pi cannot access that url. Does the pi have access to the internet? If so try again in case it was a temporary network issue.
If you still get the same error then connect to the pi in a terminal and run
ping registry.npmjs.org
If that fails then you have a network issue preventing access to that url. Check on your PC (which I assume is on the same network) that in a browser you can browse to https://registry.npmjs.org/node-red-contrib-usb

Hey, I got the solution, the name server didn´t worked.

But now I get another error:

2021-01-14T11:57:16.425Z installieren : node-red-contrib-usb 1.0.0

2021-01-14T10:57:06.418Z npm install --no-audit --no-update-notifier --save --save-prefix="~" --production node-red-contrib-usb@1.0.0
2021-01-14T10:57:29.123Z [out] 
2021-01-14T10:57:29.123Z [out] > usb@1.6.3 install /home/pi/.node-red/node_modules/usb
2021-01-14T10:57:29.123Z [out] > prebuild-install --verbose || node-gyp rebuild
2021-01-14T10:57:29.123Z [out] 
2021-01-14T10:57:33.575Z [err] prebuild-install
2021-01-14T10:57:33.583Z [err]  
2021-01-14T10:57:33.583Z [err] info
2021-01-14T10:57:33.584Z [err]  begin Prebuild-install version 5.3.6
2021-01-14T10:57:33.610Z [err] prebuild-install
2021-01-14T10:57:33.611Z [err]  info looking for cached prebuild @ /home/pi/.npm/_prebuilds/e00ec3-usb-v1.6.3-node-v64-linux-arm.tar.gz
2021-01-14T10:57:33.613Z [err] prebuild-install
2021-01-14T10:57:33.613Z [err]  http request GET https://github.com/tessel/node-usb/releases/download/v1.6.3/usb-v1.6.3-node-v64-linux-arm.tar.gz
2021-01-14T10:57:34.031Z [err] prebuild-install
2021-01-14T10:57:34.032Z [err]  http 404 https://github.com/tessel/node-usb/releases/download/v1.6.3/usb-v1.6.3-node-v64-linux-arm.tar.gz
2021-01-14T10:57:34.062Z [err] prebuild-install
2021-01-14T10:57:34.063Z [err]  WARN install No prebuilt binaries found (target=10.19.0 runtime=node arch=arm libc= platform=linux)
2021-01-14T10:57:44.848Z [out] make: Verzeichnis „/home/pi/.node-red/node_modules/usb/build“ wird betreten
2021-01-14T10:57:44.856Z [out]   CC(target) Release/obj.target/libusb/libusb/libusb/core.o
2021-01-14T10:57:47.224Z [out]   CC(target) Release/obj.target/libusb/libusb/libusb/descriptor.o
2021-01-14T10:57:49.001Z [out]   CC(target) Release/obj.target/libusb/libusb/libusb/hotplug.o
2021-01-14T10:57:49.599Z [out]   CC(target) Release/obj.target/libusb/libusb/libusb/io.o
2021-01-14T10:57:51.396Z [out]   CC(target) Release/obj.target/libusb/libusb/libusb/strerror.o
2021-01-14T10:57:51.780Z [out]   CC(target) Release/obj.target/libusb/libusb/libusb/sync.o
2021-01-14T10:57:52.288Z [out]   CC(target) Release/obj.target/libusb/libusb/libusb/os/poll_posix.o
2021-01-14T10:57:52.629Z [out]   CC(target) Release/obj.target/libusb/libusb/libusb/os/threads_posix.o
2021-01-14T10:57:52.921Z [out]   CC(target) Release/obj.target/libusb/libusb/libusb/os/linux_usbfs.o
2021-01-14T10:57:56.786Z [out]   CC(target) Release/obj.target/libusb/libusb/libusb/os/linux_udev.o
2021-01-14T10:57:57.012Z [err] ../libusb/libusb/os/linux_udev.c:40:21: fatal error: libudev.h: Datei oder Verzeichnis nicht gefunden
2021-01-14T10:57:57.012Z [err]  #include <libudev.h>
2021-01-14T10:57:57.012Z [err]                      ^
2021-01-14T10:57:57.012Z [err] compilation terminated.
2021-01-14T10:57:57.021Z [out] libusb.target.mk:140: die Regel für Ziel „Release/obj.target/libusb/libusb/libusb/os/linux_udev.o“ scheiterte
2021-01-14T10:57:57.021Z [out] make: Verzeichnis „/home/pi/.node-red/node_modules/usb/build“ wird verlassen
2021-01-14T10:57:57.021Z [err] make: *** [Release/obj.target/libusb/libusb/libusb/os/linux_udev.o] Fehler 1
2021-01-14T10:57:57.026Z [err] gyp
2021-01-14T10:57:57.028Z [err]  
2021-01-14T10:57:57.029Z [err] ERR! 
2021-01-14T10:57:57.029Z [err] build error 
2021-01-14T10:57:57.032Z [err] gyp
2021-01-14T10:57:57.032Z [err]  ERR! stack
2021-01-14T10:57:57.032Z [err]  Error: `make` failed with exit code: 2
2021-01-14T10:57:57.032Z [err] gyp
2021-01-14T10:57:57.033Z [err]  ERR! stack
2021-01-14T10:57:57.033Z [err]      at ChildProcess.onExit (/usr/share/node-gyp/lib/build.js:262:23)
2021-01-14T10:57:57.033Z [err] gyp 
2021-01-14T10:57:57.033Z [err] ERR! 
2021-01-14T10:57:57.033Z [err] stack     at ChildProcess.emit (events.js:198:13)
2021-01-14T10:57:57.033Z [err] gyp ERR!
2021-01-14T10:57:57.033Z [err]  stack
2021-01-14T10:57:57.034Z [err]      at Process.ChildProcess._handle.onexit (internal/child_process.js:248:12)
2021-01-14T10:57:57.035Z [err] gyp
2021-01-14T10:57:57.035Z [err]  ERR! System
2021-01-14T10:57:57.036Z [err]  Linux 4.19.95-rt38-v7+
2021-01-14T10:57:57.036Z [err] gyp
2021-01-14T10:57:57.036Z [err]  ERR! 
2021-01-14T10:57:57.037Z [err] command
2021-01-14T10:57:57.037Z [err]  "/usr/bin/node" "/usr/bin/node-gyp" "rebuild"
2021-01-14T10:57:57.037Z [err] gyp
2021-01-14T10:57:57.037Z [err]  ERR!
2021-01-14T10:57:57.037Z [err]  cwd
2021-01-14T10:57:57.037Z [err]  /home/pi/.node-red/node_modules/usb
2021-01-14T10:57:57.037Z [err] gyp
2021-01-14T10:57:57.038Z [err]  ERR!
2021-01-14T10:57:57.038Z [err]  node -v
2021-01-14T10:57:57.038Z [err]  v10.19.0
2021-01-14T10:57:57.038Z [err] gyp 
2021-01-14T10:57:57.038Z [err] ERR! node-gyp -v
2021-01-14T10:57:57.038Z [err]  v3.8.0
2021-01-14T10:57:57.039Z [err] gyp
2021-01-14T10:57:57.039Z [err]  ERR!
2021-01-14T10:57:57.039Z [err]  not ok
2021-01-14T10:57:57.039Z [err]  
2021-01-14T10:57:58.107Z [err] npm ERR! code ELIFECYCLE
2021-01-14T10:57:58.107Z [err] npm ERR! errno 1
2021-01-14T10:57:58.115Z [err] npm ERR! usb@1.6.3 install: `prebuild-install --verbose || node-gyp rebuild`
2021-01-14T10:57:58.115Z [err] npm ERR! Exit status 1
2021-01-14T10:57:58.115Z [err] npm ERR! 
2021-01-14T10:57:58.116Z [err] npm ERR!
2021-01-14T10:57:58.120Z [err]  Failed at the usb@1.6.3 install script.
2021-01-14T10:57:58.120Z [err] npm ERR! This is probably not a problem with npm. There is likely additional logging output above.
2021-01-14T10:57:58.189Z [err] 
2021-01-14T10:57:58.189Z [err] npm ERR! A complete log of this run can be found in:
2021-01-14T10:57:58.189Z [err] npm ERR!     /home/pi/.npm/_logs/2021-01-14T10_57_58_166Z-debug.log
2021-01-14T10:57:58.228Z rc=1

Try, if you have not already, installing whatever in your OS is the equivalent of build-essential in Debian based distributions.

I see on the node's page in the flows directory that it has not been updated for over 5 years, so it is highly likely that it does not work any more.
However, if you want to carry on, there is an issue relating to this on the node's github page, submitted in 2016 and not addressed, that suggests that you may get over this issue by installing libudev-dev. So if your OS uses apt then
sudo apt-get install libudev-dev

[Edit] Also see this issue Please update the package · Issue #8 · rajeshsola/node-red-addons · GitHub