Node-red-contrib-vcgencmd with docker compose

I have read the info at node-red-contrib-vcgencmd (node) - Node-RED, but I can't get it to work with Docker compose, whic I use for all Docker needs. I have added these to the yml file:

      - LIBRARY_PATH=/opt/vc/lib
      - /dev/vchiq:/dev/vchiq
      - /opt/vc:/opt/vc:ro

I get "The /opt/vc/bin/vcgencmd command is not supported by this hardware platform" from the node. Do anybody have this running with Docker compose? I have tried with LD_LIBRARAY_PATH too.

Purely a guess but I’d say that the low level commands required are not supported by alpine Linux that the containers are built on. You may need to use the Debian based containers instead


@dceejay Thank you very much for answering! I didn't even know that there were different builds... That shows how much I know. I'm now off to the big Internet to find a Debian based container! :+1:

See Docker

Yep, thanks, I found it. It broke some other stuff, but doing a reinstall of all palette nodes fixed that. Unfortunately the error message is still the same. :frowning:

Found a better solution - Glances:

It gives me a lot more info than the vcgencmd too! :grin:

Edit: And I'm running Glances in a Docker container too, with Docker Compose. One step closer to having a full on setup that I can just copy config files and the directory with subdirectories for each container I need onto a new Pi and have it up and running within minutes. This process takes a bit of time, but with my multitude of Pi's running Node-RED and other software in the house, cabin, boat and car, it will save me loads later.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.