Node Red Dashboard Chart Time axis (x axis) doesn't move

Hey guys,

Node Red Dashboard Chart Time axis (x axis) doesn't move sometimes. Only the Y axis data updates in the same position. Therefore I can see only a straight line always. Please see the images attached.

Thanks in advanced.


I often see the same thing. Just refresh your browser, it will come good. That's what I do.

1 Like

thanks for the reply. Yeah. Sometimes even I refresh still the issue is there, that's why i thought to ask about it in the forum.
-Jude

What is the data you ate sending to the chart ? Can you show us a debug of it ?

1 Like

Yes. sure. thanks for the reply. I have attached the debug image. These data I'm sending to those two charts.

(i'm sending only the Y axis data) So X axis suppose to be the time axis as i have selected.

23423

hmm - indeed that is most odd...
clutching at straws here... what happens if you change the X-axis label format ?

1 Like

I tried. Still the same. This happens so randomly and even it get fixed sometimes. Unfortunately still I have the issue. If I'm not mistaken, this can be a small bug.

Are you pre-loading the chart with data or does it start empty and you just add data points?

It might be useful if you restart node red in a terminal and post the startup log showing the versions of everything.

1 Like

Ok - will keep an eye out for more instances - if anyone can reproduce this "reliably" so we can get a handle on it please shout...

1 Like

Thanks for the reply. Really appreciate you all. This node red is not running on windows based PC. I'm using node red in Weidmuller ur20-wl2000-ac Controller. It's a all in one ARM based controller which has Node-Red also inside pre installed. I'm using this device to automate different industrial applications.

Right now I'm getting these data real time from Safety light curtains which connected to my U-Controller. So by using Global Variables I'm getting those data to Node-Red. Therefore I'm sorry that, I cannot open the terminal and get the log just like on windows.

Are you able to determine the versions of node-red, nodejs and node-red-dashboard?
Are you able to upgrade them if necessary?

1 Like

yes when I update the firmware of the controller, it automatically upgrade the node red to the latest version available. I didn't check the dashboard version since recently I installed dashboard palettes after resetting the device. But if necessary i can update them also.

Thanks for the reply

I see the problem in Node-RED ver 1.0.6 and Dashboard ver 2.22.1 Running on Windows 10 Home.
Nodejs version 10.16.3
Also on Node-RED 1.0.3 and Dashboard 2.22.1 running on an ARM32 platform (Industrial hardware).
Dont have shell access at the moment to get the Nodejs version (sorry).

1 Like

I will also check the versions and mention here soon.
windows based: Nodered version 1.0.6 Dashboard v2.22.1
ARM based: Nodered v1.0.3, Dashboard v2.21

Hi, I am having the same issue. Node red is running on Raspberry Pi 3 B+.

Some times I can fix it by changing the chart type to something else then back to Line chart. Refreshing my browser seems to do nothing at all, same for rebooting the Pi.

Anyone found a fix?