Node-red Exec node python code with Mac

#1

Hello everyone i am working on a project where i have data from a sensor reading by arduino and arduino process the data using python and want to communicate with node-red

what i am trying to do is i am using a mac i want to execute a python script.
let say i am printing number when that script is executed

for x in range(2):
print(x)

python3 /Users/soumilshah/Downloads/debug.py

thats the path
i tried exec node to execute path that doesn't work
i am using a mac can anyone help me out

0 Likes

#2

Sorry but that was clear as mud or I'm over tired but I'm not sure what you are doing.

When you are describing a problem is is a good idea to give an overview like

================
"I'm running Node-RED (v0.19.5) on a Mac. I have a DHT33 sensor being read by an arduino. I'm sending the data to the Mac using MQTT but I can't get it to work. I know that MQTT is working because I added two test flows: one that sends amsg via MQTT and one that receives MQTT msgs and the debug shows it working.

Attached is my flow (configured per the directions at How to share code or flow json)

Anyone have any suggestions?

===================
you say let say i am printing number when that script is executed
Now I read that and say "Hmmm I wish he had said if he was printing the number on the mac or he is printing it with the arduino. I wonder if he is using serial to connect the arduino to the mac and what protocol he is using. And what script is he executing and how did it get started?

For what it is worth, I (and many others on the forum) have many sensors being read using WeMos's and sending the data via MQTT. I install ESPeasy on the WeMos which makes reading and sending the data very easy. I send the data to a Pi or a flow running on my Mac.

0 Likes

#3

Thanks for information I just joined forum today itself I will make sure to post a complete details whenever I post next time my problem.

0 Likes

#4

so you mo longer have the problem?

0 Likes

#5

No sir someone just solved it

Thanks for help

0 Likes

#6

So in order to help anyone who finds this thread in the future, what did you do? How did you solve it?

0 Likes