Node-Red Install

Hey i run my Node-Red locally on my Laptop. That works well with:
nodejs -v = v15.10.0 and npm -v = 7.6.0. I did this in March.

Now i want to install Node-Red on a Windows Server 2012 R2.

First i downloaded the newest version from
I run the Setup
The node -v = v16.0.0 and npm -v = 7.10.0

now i want to install node-red so i did:
npm config set registry http//
After this i used this code:
npm install -g --unsafe-perm node-red

The Error i got is:
npm ERR! code E503
npm ERR! 503 Service Unavailable - GET

I don`t know how to solve this problem... any help?

Can you open in your browser directly?

npm config set registry http//

You shouldn't normally need to do that - npm will default to the public npm registry.

Are you running behind any sort of proxy or firewall?

i can open the like in my browser directly.

How can I see if I am behind a proxy?
( ```
npm config get proxy
npm config get https-proxy

both return null

Likely not the issue here, but has any testing been done with nodejs 16?

Are you able to npm install anything other module? For example, create a temporary directory and run npm install cowsay2.

@Colin not the issue here. We're currently blocked on testing with Node 16 due to upstream devDependencies not supporting it yet.

maybe I go back to the setup which i use on my locally...
But there i got another question if i run this setup i get not npm - v = 7.6.0
I receive 7.5.3 how can i update that or change that? because the 7.5.3 is not working there..
Any Ideas ? I did it in March but cannot recognize :X

I didn't think it was causing the issue with the registry, but even when that is surmounted it would be best to go back to 14 I assume.

14.16.1?? This?

Yes, that is the latest node red supported version. Supported Node versions : Node-RED

so I downloaded it.
Then i run the Setup

node -v = v14.16.1
npm -v = 6.14.12

npm install -g --unsafe-perm node-red
=> npm ERR! code E503
=> npm ERR! 503 Service Unavailable - GET

npm config get proxy
=> null

npm config get https-proxy
=> null

As I said, that isn't the cause of the registry issue. You said that works ok in a browser, is that running the browser on the Windows Server machine, not on the laptop?

damn it... there is the problem... its a server at Work. and There i cannot go on that webside..

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.