Node-RED must be restarted to enable upgraded modules

#1

Hi, I tried to update a module but it doesn't and display this, I tried to typ in console node-red-stop, node-red,start dut it didn't help, then I did a sudo restart and it worked.
How to restart then Node red without reboot? Thank you

0 Likes

#2

depends what you are running Node-Red on and how you installed it.

0 Likes

#3

I installed it as you suggested, without root,
I used the command line to start it up automatically after reboot as you suggested.
Thank you for help

0 Likes

#4

I’m sorry I can’t remember ever suggesting to you how you should install Node-RED.
Or suggesting a command line to start Node-RED automatically.

Is this on a Raspberry Pi?
Do you mean the Instructions on the website? If so that isn’t me, I’m not that clever! I’m just a long term user of Node-RED who answer questions on the forum when I can.

0 Likes

#5

Yes the instruction on the site, yes Raspberry )

0 Likes

#6

What output do you get when you run node-red-stop?

0 Likes

#7

and node-red-start (not node-red,start )

0 Likes

#8

Mates I don't create subflows, I'm a newbie and I'm using modules in the main flow only, I suppose it is something created by a module itself..

here it is: (i tried to remove // from links

pi@raspberrypi:~ $ node-red-stop

Stop Node-RED

Use node-red-start to start Node-RED again

pi@raspberrypi:~ $ node-red-start

Start Node-RED

Once Node-RED has started, point a browser at http: 192.168.1.251:1880
On Pi Node-RED works better with the Firefox or Chrome browser

Use node-red-stop to stop Node-RED
Use node-red-start to start Node-RED again
Use node-red-log to view the recent log output
Use sudo systemctl enable nodered.service to autostart Node-RED at every boot
Use sudo systemctl disable nodered.service to disable autostart on boot

To find more nodes and example flows - go to http://flows.nodered.org

Starting as a systemd service.
Started Node-RED graphical event wiring tool.
6 Feb 19:54:29 - [info]
Welcome to Node-RED

6 Feb 19:54:29 - [info] Node-RED version: v0.19.5
6 Feb 19:54:29 - [info] Node.js version: v10.15.0
6 Feb 19:54:29 - [info] Linux 4.14.79-v7+ arm LE
6 Feb 19:54:30 - [info] Loading palette nodes
6 Feb 19:54:40 - [info] Dashboard version 2.13.0 started at /ui
6 Feb 19:54:40 - [info] Settings file : /home/pi/.node-red/settings.js
6 Feb 19:54:40 - [info] Context store : 'default' [module=memory]
6 Feb 19:54:40 - [info] User directory : /home/pi/.node-red
6 Feb 19:54:40 - [warn] Projects disabled : editorTheme.projects.enabled=false
6 Feb 19:54:40 - [info] Flows file : /home/pi/.node-red/flows_raspberrypi.json
6 Feb 19:54:40 - [info] Server now running at http: 127.0.0.1:1880/
6 Feb 19:54:40 - [warn]

Your flow credentials file is encrypted using a system-generated key.
If the system-generated key is lost for any reason, your credentials
file will not be recoverable, you will have to delete it and re-enter
your credentials.
You should set your own key using the 'credentialSecret' option in
your settings file. Node-RED will then re-encrypt your credentials
file using your chosen key the next time you deploy a change.

6 Feb 19:54:41 - [info] Starting flows
pi : TTY=unknown ; PWD=/home/pi ; USER=root ; COMMAND=/usr/bin/python -u /home/pi/.node-red/node_modules/node-red-contrib-lcd20x4-i2c/LCD20x4-I2C/lcd20x4_i2c.py writelcd 20x4 2
pam_unix(sudo:session): session opened for user root by (uid=0)
6 Feb 19:54:42 - [info] [mosca in:50deaca8.77738c] Binding mosca mqtt server on port: 1883
6 Feb 19:54:42 - [info] [tcp out:Dimmer WiFi Bridge] connecting to 192.168.1.254:8899
6 Feb 19:54:42 - [info] [tcp out:Denon Amplificatore] connecting to 192.168.1.252:23
6 Feb 19:54:43 - [info] Started flows
6 Feb 19:54:43 - [info] [mqtt-broker:mqtt] Connection failed to broker: mqtt://192.168.1.251:1883
6 Feb 19:54:43 - [info] [tcp out:Dimmer WiFi Bridge] connected to 192.168.1.254:8899
6 Feb 19:54:43 - [info] [tcp out:Denon Amplificatore] connected to 192.168.1.252:23
6 Feb 19:54:58 - [info] [mqtt-broker:mqtt] Connected to broker: mqtt: 192.168.1.251:1883

0 Likes

#9

As you can see, the node node-red-contrib-lcd20x4-i2c is showing an error. Did you follow the instructions for installing it in the readme?

[Edit] Actually I am not sure that is an error, it may just be informational. So what exactly is the problem that you are seeing?

0 Likes

#10

Thank you for your help, anyway here I'm trying to figure how I can upgrade modules without a sudo reboot. node-red-stop and node-red-start are not enough. Thank you

0 Likes

#11

Well, yes they are enough. They stop the node-red process and restart it. That is all that is needed.

Did you reload the editor after restarting node-red?

0 Likes

#12

Yes I did, and it keep say me that for upgrade neds to restart. I solved the problem only after sudo reboot.
I suppose there is a service installed, which is not killing itself and reload, it keeps worjing and it just stop execute something (for example flow) but it is not killed. I suppose, the only answer why it needed reboot..

0 Likes

#13

Where is it saying that? That suggests you have upgraded or installed some system related software.

0 Likes

#14

I wrote m that to upgrade modules I need to restart Node Red. Pity I haven't made a photo (
stop and restart didn't help. It helped sudo reboot.
Any chance to restart node red as it asked without reboot?
Thank you

0 Likes

#15

@Barabba11

Yes, as we have said many times, node-red-stop and node-red-start is what is needed. Those are the commands to stop and restart the node-red service. The flag to say a restart is needed is only held in memory - if the node process is stopped, the flag will be wiped.

So clearly something else is going on here.

After running node-red-stop can you check that node-red has really been stopped? Try reloading the editor - it should fail. Check the node process has been stopped (ps -ef | grep node will give you a list of node processes - there shouldn't be one).

0 Likes

#16

Ok thanks for clear it, next time I'll check!

0 Likes

#17

I have a dubt/question, if I load on boot node red with sudo systemctl enable nodered.service, can I stop it with node-red-stop in a SSH console just opened?
I think I checked already that the web was not responding, and start it again from SSH, but it still display that error. I guess I did.. maybe was tha chache of browser?

PS: it's always me, with another laptop. I had to ask something in past and my password didn't work there, so I used github account for logging in

0 Likes

#18

Yes.
After stopping you can sudo systemctl status nodered to check it is stopped. Do it before the stop aswell, to see the difference.

0 Likes

#19

Hi, I confirm you it was just a mistake of browser, doing a node-red-stop, followed by a start and refreshing completely the browser page solved it. Thank you

0 Likes