Constant Node-RED must be restarted to enable upgraded modules

I have run into a bit of a problem that I don't know how to resolve.

I run on a raspberry pi. I was a couple of versions behind the latest. 1.10 I think
I updated the openweathermap node from within pallet manager.
But now despite restarting (node-red-stop & node-red-start) I cannot get rid of the message.

I have ran the recommended upgrade script and am now on 1.13 but still the same error.

When I start I get

21 Nov 15:39:35 - [info] Node-RED version: v1.2.5
21 Nov 15:39:35 - [info] Node.js  version: v12.19.1
21 Nov 15:39:35 - [info] Linux 4.19.66-v7+ arm LE
21 Nov 15:39:36 - [info] Loading palette nodes
21 Nov 15:39:40 - [info] Settings file  : /home/pi/.node-red/settings.js
21 Nov 15:39:40 - [info] Context store  : 'default' [module=memory]
21 Nov 15:39:40 - [info] User directory : /home/pi/.node-red
21 Nov 15:39:40 - [warn] Projects disabled : editorTheme.projects.enabled=false
21 Nov 15:39:40 - [info] Flows file     : /home/pi/.node-red/flows_pi1.json
21 Nov 15:39:40 - [info] Creating new flow file
21 Nov 15:39:40 - [warn]
---------------------------------------------------------------------
Your flow credentials file is encrypted using a system-generated key.
If the system-generated key is lost for any reason, your credentials
file will not be recoverable, you will have to delete it and re-enter
your credentials.
You should set your own key using the 'credentialSecret' option in
your settings file. Node-RED will then re-encrypt your credentials
file using your chosen key the next time you deploy a change.
---------------------------------------------------------------------
21 Nov 15:39:40 - [info] Starting flows
21 Nov 15:39:40 - [info] Started flows
21 Nov 15:39:40 - [info] Server now running at http://127.0.0.1:1880/

Any guidance gratefully received.

Clear the browser cache and refresh the page.
However, did you see the message:

that means that it has not found your old flows file (if you had one), so either it was in a different folder or node-red is looking at the wrong file. Have a look in that folder and see what flows*.json files there are there.

Thanks Colin

I have deleted browser cache and also tried another browser. The message persists.

All my flows are there but get that message every time when I do node-red-start?

Edit: There are no flows*.json files in the .node-red directory

Something is messed up here:

node-red-start reports version 1.2.5 in the console but accessing the flows from the browser shows 1.1.3 !!!.

Are you running the browser on the pi or on another machine?
What url are you entering to see node-red? Are you sure you are looking at the right pi?

1 Like

Colin you are 100% correct.
I have been a complete idiot and installed node-red on the wrong Pi :blush:

I have now ran the bash script on the correct Pi and am fully up to date and most importantly working again without the restart message.

Thanks for bearing with me. I will now go somewhere quiet to try and regain my sanity

Many is the time I have been typing away in an ssh terminal window not able to work out why I am not seeing the results I expect, only to realise that I am in the wrong window. :slight_smile:

1 Like