node-RED can not be opened anymore

#1

I ran Node-RED on a Pi, it ran fine until last night. After a deploy I lost the connection to Node-RED. And it can not be called up until now. I can start node-RED but I can not reach it via the browser anymore!
What can I do??

0 Likes

#2

you have a warning

Projects disabled: editorTheme.projects.enabled = false

Maybe it's this

But I don´t know, whats the warning means

0 Likes

#3

I think this is not the reason because if I change the editorTheme setting in the settings.js file the warning change to:
No active project: using default flows file.

but there is still anoher warining, but no comment with indicates.

it appears only: the date - [warn]

0 Likes

#4

Projects disabled =false is fine.
You can read up about the projects feature in the blog (see top of screen)

Step 1 the basics : the ip address that Node-RED is now running on is printed in your screenshot.
Have you double checked that’s the up address you are trying to access?

After that what had you done before your last deploy?
Was it installing an extra node? Upgrading a node? Using a new node?

If not you have two nodes with errors ui_bild and
securedhttp . I’d start by uninstalling them and seeing if the problem goes away.

0 Likes

#5

I have triple checked the ip address,

the two errors have been there for a long time.

I recently added something to the topbar, and after a deploy, the connection was weng and I have not been able to grab it since.

I have no new nodes or similar installed or updated

0 Likes

#6

another thing ist that the command: node-red-stop takes a long time

0 Likes

#7

What did you add to the top bar?

Try starting with a new flows file. Move your current flows file to a different name and then restart node-red

0 Likes

#8

how do I change the flow file ?

in the settings.js file under flowFile I write a file name and copy into this file my flow and save it under ~ / .node-red?

0 Likes

#9

I add a button to the topBar

0 Likes

#10

your flows file is specified in your image try moving it to a different name and restart node-red

0 Likes

#11

I changed it to flow_new.json

but nothing happend

0 Likes

#12

Well the good news is that its not something in your flow so you can move it back.
and Node-red is running you just can't access it.

This means it has to be something in your install.

Have you installed any "dashboards" recently - any other nodes that say they have dashboard functionality. If so I would start by removing them ( and removing the two that Node-RED is complaining about as well)

0 Likes

#13

No the only dashboard i have installed is the node-red-dashboard.

after I removed the two they are still in there!

but in the node_modules file both are not existing.

0 Likes

#14

but you aren't in the correct directory to run that command.

cd .node-red

0 Likes

#15

ok I run the command now in the correct directrory, now this appears

0 Likes

#16

Those are just warnings (about the nodes you removed). They should not appear again.
By the way it is better, if possible, to copy/paste here rather than insert images. You can copy/paste from the terminal using Ctrl-Shift-C. When pasting logs use the same technique for making sure they show ok as is used for code/flows.

0 Likes

#17

ok the next log i will share so.

After a new reboot of node-red the warning don´t appear again.

pi@H0028631:~ $ node-red-stop

Stop Node-RED
 
Use   node-red-start   to start Node-RED again
 
pi@H0028631:~ $ node-red-start
#
Start Node-RED
 
Once Node-RED has started, point a browser at http://10.21.42.235:1880
On Pi Node-RED works better with the Firefox or Chrome browser
 
Use   node-red-stop                          to stop Node-RED
Use   node-red-start                         to start Node-RED again
Use   node-red-log                           to view the recent log output
Use   sudo systemctl enable nodered.service  to autostart Node-RED at every boot
Use   sudo systemctl disable nodered.service to disable autostart on boot
 
To find more nodes and example flows - go to http://flows.nodered.org
 
Starting as a systemd service.
Started Node-RED graphical event wiring tool.
9 Jan 10:17:18 - [info]
Welcome to Node-RED
===================
9 Jan 10:17:18 - [info] Node-RED version: v0.19.5
9 Jan 10:17:18 - [info] Node.js  version: v8.12.0
9 Jan 10:17:18 - [info] Linux 4.14.70-v7+ arm LE
9 Jan 10:17:19 - [info] Loading palette nodes
9 Jan 10:17:22 - [info] Dashboard version 2.12.2 started at /ui
9 Jan 10:17:23 - [info] Settings file  : /home/pi/.node-red/settings.js
9 Jan 10:17:23 - [info] HTTP Static    : /home/pi/Pictures
9 Jan 10:17:23 - [info] Context store  : 'default' [module=memory]
9 Jan 10:17:23 - [info] User directory : /home/pi/.node-red
9 Jan 10:17:23 - [warn] Projects disabled : editorTheme.projects.enabled=false
9 Jan 10:17:23 - [info] Flows file     : /home/pi/.node-red/flow_new.json
9 Jan 10:17:23 - [info] Server now running at http://127.0.0.1:1880/
9 Jan 10:17:23 - [warn]
---------------------------------------------------------------------
Your flow credentials file is encrypted using a system-generated key.
If the system-generated key is lost for any reason, your credentials
file will not be recoverable, you will have to delete it and re-enter
your credentials.
You should set your own key using the 'credentialSecret' option in
your settings file. Node-RED will then re-encrypt your credentials
file using your chosen key the next time you deploy a change.
---------------------------------------------------------------------
9 Jan 10:17:23 - [info] Starting flows
9 Jan 10:17:23 - [error] [users_config:86a81de6.9ee2d] Node users config is missing
Secret =  Hans
2019-01-09 09:17:24: Connecting to modbustcp slave at 192.168.1.5:502 unit_id: 1
2019-01-09 09:17:24: Connecting to modbustcp slave at 192.168.1.5:502 unit_id: 1
2019-01-09 09:17:24: Connecting to modbustcp slave at 192.168.1.5:502 unit_id: 1
2019-01-09 09:17:24: Connecting to modbustcp slave at 192.168.1.5:502 unit_id: 1
9 Jan 10:17:24 - [info] Started flows

but what is with the [warn] without any comment?

0 Likes

#18

That warn is about the following credentials message.
I see you have an error there still

9 Jan 10:17:23 - [error] [users_config:86a81de6.9ee2d] Node users config is missing
Secret =  Hans

Do you know what that is about? If not then you can search for the node id (86a81de6.9ee2d) using the Search feature under the hamburger menu to find that node to see what is wrong.

0 Likes

#19

what is the hamburger menu?

this would have to be because i used the node-red-contrib-user node. Actually, I also uninstalled this

0 Likes

#20

The three lines in the top right
image

Do you mean you get this message after uninstalling? In which case there is likely an unused config node left. When you click Deploy you should see a message saying Unused Config Nodes. Click that and it will take you to it so you can delete it. Alternatively you can get to the config nodes from the hamburger menu and will see unused ones. To delete it open it and click Delete

0 Likes