Node Red openzwave problems

hi there.
my Pi3 has raspian running and i work on Node red V 0.20.8
this machine is running since months and now i bought a Z-Wave Stick (Everspring Z-Wave+ USB-Controller).
I tried to install "node-red-contrib-openzwave-am" and its depencies. when "node-red-contrib-openzwave-am" is installed Node Red crashes and can´t start because of openzwave.

somewhere on the net somebody said delete everything with "openzwave" and reinstall everything.
i did what he/she told in the thread but openzwave-shared can´t be installed.

errormessage tells me sonething is missing (maybe something i deleted)

/usr/bin/ld: -lopenzwave kann nicht gefunden werden
collect2: error: ld returned 1 exit status
make: *** [ Release/] Fehler 1
make: Verzeichnis „/home/pi/.node-red/node_modules/openzwave-shared/build“ wird verlassen
gyp ERR! build error
gyp ERR! stack Error: `make` failed with exit code: 2
gyp ERR! stack     at ChildProcess.onExit (/usr/local/lib/node_modules/npm/node_modules/node-gyp/lib/build.js:194:23)
gyp ERR! stack     at ChildProcess.emit (events.js:189:13)
gyp ERR! stack     at Process.ChildProcess._handle.onexit (internal/child_process.js:248:12)
gyp ERR! System Linux 4.19.58-v7+
gyp ERR! command "/usr/bin/node" "/usr/local/lib/node_modules/npm/node_modules/node-gyp/bin/node-gyp.js" "rebuild"
gyp ERR! cwd /home/pi/.node-red/node_modules/openzwave-shared
gyp ERR! node -v v10.15.2
gyp ERR! node-gyp -v v5.0.5
gyp ERR! not ok
npm ERR! errno 1
npm ERR! openzwave-shared@1.5.10 install: `node-gyp rebuild`
npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the openzwave-shared@1.5.10 install script.
npm ERR! This is probably not a problem with npm. There is likely additional logging output above.

npm ERR! A complete log of this run can be found in:
npm ERR!     /home/pi/.npm/_logs/2019-12-29T20_29_38_818Z-debug.log

now i have:
Node Red V 0.20.8
openzwave (1.5+ds-6). (/usr/lib/arm-linux-gnueabihf/

i don´t have:

please can someone help me?

I haven't installed openzwave so I don't know

/ usr / bin / ld: -lopenzwave  kann nicht gefunden werden (could not be found)

That's saying the openzwave library file is missing which seems to agree with your statement:

i don´t have:

I think it would be best if you installed openzwave ( node-openzwave-shared and it's dependencies) and made sure it worked then installed the node-red nodes.

I installed node-red-contrib-openzwave-am via manage palette, restarted node-red and it was working.

@Maximus1 - try upgrading node, as you are running 10.15

Now i got everything installed and get informations from nodes. While fetching data the pi 3+ gets laggy.
How do i store the data and how do i set temperatures on the thermostats?

In this topic I have given an example

Dont i need to include the nodes?
How do i do this?

i got it to work with this Flow but it is not womans compatible. so i need something better looking.

i tried your example but i think i did not understand the whole thing. when i try to send a command to a node nothing happes or i get json errors in the debug panel.

[{"id":"eb9e5ec9.20542","type":"zwave-out","z":"42de9a37.0c6184","name":"write","controller":"e3505a4b.c72c38","x":750,"y":200,"wires":[["11a8b04a.9eaa1"]]},{"id":"95879a83.da4d08","type":"inject","z":"42de9a37.0c6184","name":"","topic":"","payload":"","payloadType":"date","repeat":"","crontab":"","once":false,"onceDelay":"","x":340,"y":200,"wires":[["931783da.89d9f"]]},{"id":"931783da.89d9f","type":"template","z":"42de9a37.0c6184","name":"","field":"payload","fieldType":"msg","format":"json","syntax":"plain","template":"nodeid: 3,cmdclass: 67,cmdidx: 1,value:\"24\"","output":"str","x":540,"y":200,"wires":[["eb9e5ec9.20542"]]},{"id":"11a8b04a.9eaa1","type":"debug","z":"42de9a37.0c6184","name":"","active":true,"tosidebar":true,"console":false,"tostatus":false,"complete":"false","x":910,"y":200,"wires":[]},{"id":"e3505a4b.c72c38","type":"zwave-controller","z":"","port":"/dev/serial/by-id/usb-0658_0200-if00","driverattempts":"3","pollinterval":"10000","allowunreadyupdates":false,"networkkey":"","logging":"full"}]

can you tell me where my mistake is?
here is my ozw config for node 3

				<Instance index="1" />
				<Value type="decimal" genre="user" instance="1" index="1" label="Heating 1" units="C" read_only="false" write_only="false" verify_changes="false" poll_intensity="0" min="0" max="0" value="20.50">
					<Help>Set the Thermostat Setpoint Heating 1</Help>

my payload from node red.

{"nodeid":3,"cmdclass":67,"cmdidx":1,"instance":1,"oldState":"20.00","currState":"20.00","label":"Heating 1","units":"C","value":{"value_id":"3-67-1-1","node_id":3,"class_id":67,"type":"decimal","genre":"user","instance":1,"index":1,"label":"Heating 1","units":"C","help":"Set the Thermostat Setpoint Heating 1","read_only":false,"write_only":false,"min":0,"max":0,"is_polled":false,"value":"20.00"},"uuid":"b827ebea682a-0xfc01a48e-3"}

after some headache i finaly got everything to work.

here is the core of my flow. there are some links to other tabs with controls. ignore or delete them if you use my flow.

Pastebin link

@Maximus1 : Thank you for sharung your flow! I took the one you published My Z-Wave heating solution . I use an aeotec z-stick gen5 stick with an raspbi 4 and node red. How can I find out the right ids for my Devolo / Danfoss thermostats and do I have to add/pair them somewhere?

And have you already implemented something from you to do list from the other thread which you might share with me too?



Hi, after long time with several errors i decided to kick that shit in a trashcan.
When it works, it works flawless but beware of that day something brake.
until there is no real support für devolo heaters and/or home control i can not recomend integration into node red.
There are so many points you can/will fail, but if you realy want send me your E-Mail and i send you a Programm to pair your heaters with your stick, or add your stick to the home control network.

To be clear. On the hardware side everything will work flawless until you need new batteies.
New batteries = huge problems with pairing and openzwave/node red/flows.

My best tip to you: use alexa with your home control, add the stick as a repeater and hope it will work for a long time.
My second best tip: put that devolo shit into a trashcan and NEVER try to integrate openzwave in your node red.

Thanks for your answer! I now used home assistant for the communication with my zwave thermostats and just want to do the ‚managment‘ of them in node red (boost-function, timeplan, open window recognisation…)… for this I am using z-wave.js in home assistant… maybe i could use some parts of your old flow for the management stuff? Would be nice if you could share it with me :slight_smile:

Up to now the communication to the thermostats seems to work quite reliable - maybe this changes after some time - lets see :wink: