Node-red to influxdb atlas scientific

Hello everyone. I am a three week in noobs so please be patient if I'm a bit slow.

I have data from two Atlas Scientific sensors coming into node red through MQTT to go to Influxdb. The value field was a string, not a number. I have changed this in the Change Node to be a number. Changed the time to a timestamp, deleted the name and the address and kept the ModuleType as it was.

I did this as Influxdb wasn't seeing the value so couldn't get it to graph. Now its not seeing the value as a field so isn't there at all.

Any idea what I am doing wrong? Thank you very much.

@grant1 @Fishy

1 Like


If you managed to pass through your value to InfluxDB as a string initially, it has now recorded it as a string so the numbers you are sending won't be right.

If that is the case, the easiest thing to do is drop and recreate the measure.

Hello TI,

Thank you very much for your reply.

When I initially sent my message to Influx it didn't see the value as a number and wouldn't work. It seems from another post on here that I had to change it to a number so it would graph it - see picture.

I've only been doing this three weeks so sorry for being stupid, but I don't understand what 'drop and recreate the measure' means?

Nope, not stupid at all. This is a very common issue with InfluxDB. It takes the data type from the first message you send it. It then will not change it.

To be honest, if you are just getting started, I would recommend dropping (deleting) the whole database and starting again.

Here is an article I posted ages back about terminology and recommended structure in InfluxDB in case it helps. Need more detailed information on influxdb - General - Node-RED Forum (nodered.org)

And don't worry, InfluxDB is mind-twisting to get started on but once you've set it up, it all "just works".

1 Like

Thank you so much. Deleted the bucket. made new bucket and it all works. Not sure if I would ever have worked that out. Finally, very happy indeed.

Both sensors don't seem to work in the same bucket. Maybe it is the way I'm sending the data or maybe I do need to use different buckets?

Thank you so much, have a great day!!!

Hi Mark, this is what i ended up doing.


Screenshot 2022-05-05 214329
Screenshot 2022-05-05 214432
Screenshot 2022-05-05 214522
Screenshot 2022-05-05 214624
PeterN

Thank you very much for your reply.

I ended up doing it slightly differently, but with the same result.

Having to delete the influxdb bucket and remake before it would see the new data got me.

Thanks,

Mark