Node-RED version 1.1 on docker, won't start on Raspberry PI 3 and archlinuxarn

I'm just installing the new version of node-red, the 1.1 version, unfortunately, it is not running with the following error:

[root@pvr ~]# docker -v run -it -p 1880:1880 --name mynodered nodered/node-red
luoghi piu' selvaggi del pianeta. Nel piu' profondo canyon del Nord America, l'avventuriero affronta un viaggio pericoloso. Dovra' evitare animali velenosi e so

SyntaxError: Unexpected identifier
at Module._compile (internal/modules/cjs/loader.js:723:23)
at Object.Module._extensions..js (internal/modules/cjs/loader.js:789:10)
at Module.load (internal/modules/cjs/loader.js:653:32)
at tryModuleLoad (internal/modules/cjs/loader.js:593:12)
at Function.Module._load (internal/modules/cjs/loader.js:585:3)
at Module.require (internal/modules/cjs/loader.js:692:17)
at require (internal/modules/cjs/helpers.js:25:18)
at Object. (/usr/local/lib/node_modules/npm/node_modules/wide-align/node_modules/string-width/index.js:2:17)
at Module._compile (internal/modules/cjs/loader.js:778:30)
at Object.Module._extensions..js (internal/modules/cjs/loader.js:789:10)
[root@pvr ~]#

The same error happens to update the previous version 1.0.6 that was working fine.

I use archlinux arm on Rasperry Pi 3.

Is there someone helping me?

I don't know what's happened, because I've tryed to installI don't know what's happened, because I've tried to install node-red in docker using raspbian and ubuntu and was working but in archlinuxarm was not working. I've reinstalled archlinuxarm on my RPI3, restored the node-red folder, and now it is working.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.