I'm receiving this error and node-red is stopping every couple hours.

[red] Uncaught Exception:
Error: read ECONNRESET
at TCP.onStreamRead (internal/stream_base_commons.js:111:27)
npm ERR! errno 1
npm ERR! node-red-docker@1.3.5 start: node $NODE_OPTIONS node_modules/node-red/red.js $FLOWS "--userDir" "/data" "--safe"
npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the node-red-docker@1.3.5 start script.
npm ERR! This is probably not a problem with npm. There is likely additional logging output above.
npm ERR! A complete log of this run can be found in:
npm ERR! /root/.npm/_logs/dateT16_41_17_082Z-debug.log

I can't find any solution
[info] Node-RED version: v1.3.5
[info] Node.js version: v10.24.1
[info] Linux 4.19.0-19-cloud-amd64 x64 LE

Welcome to the forum @energyplot

Have you installed any non-builtin nodes?

[Edit] Also look in the log file mentioned to see if there is any additional information.

I just installed: node-red-contrib-modbus, node-red-contrib-ignition-nodes, node-red-node-ping.
I can not see something clear in log file:

2 info using npm@6.14.12
3 info using node@v10.24.1
4 verbose run-script [ 'prestart', 'start', 'poststart' ]
5 info lifecycle node-red-docker@1.3.5~prestart: node-red-docker@1.3.5
6 info lifecycle node-red-docker@1.3.5~start: node-red-docker@1.3.5
7 verbose lifecycle node-red-docker@1.3.5~start: unsafe-perm in lifecycle true
8 verbose lifecycle node-red-docker@1.3.5~start: PATH: /usr/local/lib/node_modules/npm/node_modules/npm-lifecycle/node-gyp-bin:/usr/src/node-red/node_modules/.bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin

9 verbose lifecycle node-red-docker@1.3.5~start: CWD: /usr/src/node-red
10 silly lifecycle node-red-docker@1.3.5~start: Args: [ '-c',
10 silly lifecycle 'node $NODE_OPTIONS node_modules/node-red/red.js $FLOWS "--userDir" "/data" "--safe"' ]
11 silly lifecycle node-red-docker@1.3.5~start: Returned: code: 1 signal: null
12 info lifecycle node-red-docker@1.3.5~start: Failed to exec start script
13 verbose stack Error: node-red-docker@1.3.5 start: node $NODE_OPTIONS node_modules/node-red/red.js $FLOWS "--userDir" "/data" "--safe"
13 verbose stack Exit status 1
13 verbose stack at EventEmitter. (/usr/local/lib/node_modules/npm/node_modules/npm-lifecycle/index.js:332:16)
13 verbose stack at EventEmitter.emit (events.js:198:13)
13 verbose stack at ChildProcess. (/usr/local/lib/node_modules/npm/node_modules/npm-lifecycle/lib/spawn.js:55:14)
13 verbose stack at ChildProcess.emit (events.js:198:13)
13 verbose stack at maybeClose (internal/child_process.js:982:16)
13 verbose stack at Process.ChildProcess._handle.onexit (internal/child_process.js:259:5)
14 verbose pkgid node-red-docker@1.3.5
15 verbose cwd /usr/src/node-red
16 verbose Linux 4.19.0-19-cloud-amd64
17 verbose argv "/usr/local/bin/node" "/usr/local/bin/npm" "start" "--" "--userDir" "/data" "--safe"
18 verbose node v10.24.1
19 verbose npm v6.14.12
20 error code ELIFECYCLE
21 error errno 1
22 error node-red-docker@1.3.5 start: node $NODE_OPTIONS node_modules/node-red/red.js $FLOWS "--userDir" "/data" "--safe"
22 error Exit status 1
23 error Failed at the node-red-docker@1.3.5 start script.
23 error This is probably not a problem with npm. There is likely additional logging output above.

Has it previously worked? If so then what changed immediately before it failed?

It can work for a some hours until it crashes. Everything seems to work fine, but every 24h I think fails with that same error. I'm trying to upgrade node and npm to a newer version. Any other idea?

I updated Node-red/NPM/NodeJS so the problem seems to be resolved

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.