Open zwave Cannot open serial port /dev/ttyUSB0

I am trying to install openzwave on a raspberry B3 with a new buster installation. So far all went ok until I started the test program MinOZW which gives me the following message
ERROR: Cannot open serial port /dev/ttyUSB0. Error code 2
how can I fix this problem. In Node-Red I also need this device.
Any help very much appreciated

yes, I have done it.

Do you have a Zwave adapter attached to the port?

Can you post the output of

ls -lah /dev/ttyUSB0

these are all my devices: I highlighted the ones starting with u.
autofs loop-control ram9 tty25 tty53 vcs5
block mapper random tty26 tty54 vcs6
btrfs-control media0 raw tty27 tty55 vcs7
bus mem rfkill tty28 tty56 vcsa
cachefiles memory_bandwidth serial tty29 tty57 vcsa1
char mmcblk0 serial0 tty3 tty58 vcsa2
console mmcblk0p1 serial1 tty30 tty59 vcsa3
cpu_dma_latency mmcblk0p2 shm tty31 tty6 vcsa4
cuse mqueue snd tty32 tty60 vcsa5
disk net stderr tty33 tty61 vcsa6
fb0 network_latency stdin tty34 tty62 vcsa7
fd network_throughput stdout tty35 tty63 vcsm
full null tty tty36 tty7 vcsm-cma
fuse ppp tty0 tty37 tty8 vcsu
gpiochip0 ptmx tty1 tty38 tty9 vcsu1
gpiochip1 pts tty10 tty39 ttyACM0 vcsu2
gpiochip2 ram0 tty11 tty4 ttyAMA0 vcsu3
gpiomem ram1 tty12 tty40 ttyprintk vcsu4
hwrng ram10 tty13 tty41 ttyS0 vcsu5
initctl ram11 tty14 tty42 uhid vcsu6
input ram12 tty15 tty43 uinput vcsu7
kmsg ram13 tty16 tty44 urandom vhci
log ram14 tty17 tty45 v4l video10
loop0 ram15 tty18 tty46 vchiq video11
loop1 ram2 tty19 tty47 vcio video12
loop2 ram3 tty2 tty48 vc-mem watchdog
loop3 ram4 tty20 tty49 vcs watchdog0
loop4 ram5 tty21 tty5 vcs1 zero
loop5 ram6 tty22 tty50 vcs2
loop6 ram7 tty23 tty51 vcs3
loop7 ram8 tty24 tty52 vcs4
pi@raspberrypi:~ $

Zugriff auf /dev/ttyUSB0' nicht möglich: Datei oder Verzeichnis nicht gefunden
this is the response to your command line. File or directory not found

in an old installation I had dev/ttyACM0 and it worked. But how can I tell openzwace to use this device instead of dev/ttyUSB0?

pi@raspberrypi:~ $ lsusb
Bus 001 Device 004: ID 0658:0200 Sigma Designs, Inc. Aeotec Z-Stick Gen5 (ZW090) - UZB
Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp. SMSC9512/9514 Fast Ethernet Adapter
Bus 001 Device 002: ID 0424:9514 Standard Microsystems Corp. SMC9514 Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

on bus 001 Device 004 I can see my zwave controller. Which /dev/ttyUSB? is this

Try MinOZW /dev/serial0

no sucess. ERROR code 13 now

is buster the problem? did something change compared to stretch?

MiniOZW /dev/ttyAMA0 ?

or sudo MinOZW /dev/serial0

did not work :frowning:
never touch a running system. On strech it ran perfectly

Any error message?

Problem fixes. Will post Solution tomorrow.

This may help simplify things a bit:

sudo dmesg -C # clear the ring (messages)

Remove the USB dongle, then run:

sudo dmesg -T # displays the message with a timestamp

Insert the USB dongle, then run:

sudo dmesg -T # displays the message with a timestamp

Now you should see the current tty assignment

this solved the problem:

I found my device and made a note of the ID xxxx:xxxx (8 numbers separated with colon)

sudo modprobe ftdi_sio

sudo bash

sh -c "echo xxxx xxxx > /sys/bus/usb-serial/drivers/ftdi_sio/new_id"
I put in the product ID I found with lsusb but without a colon separator

in order to get a clean system and user pi

cd Home/pi/open-zwave

./MinOZW dev/ttyACM0 (no error :slight_smile: )

I used dev/ttyACM0 in node red and it worked!