OpenSSL Certificate not working

Hi, did anyone tried to use the free openssl generate for the self signed certificate and get the connection secure? I tried few method from internet like importing the cert.pem into the trusted root certification authorities but the connection still Not in secure. Or I need to use a paid CA for getting the secure connection? :persevere:

Hi @jan-k,
You have issued your certificate to the domain WTP088089 (as I can see in the certificate screenshot), but you navigate to
So the browser sees that this doesn't match.
You should navigate in your browser to wtp088089:1880 instead.
Please start a new discussion next time, because this has nothing to do with the certbot explanation...

1 Like

Yes, I did try to navigate to it but still the same.

But I assume you know get another error reason??? I assume it is not valid anymore, because your certificate is only valid from 6/3/2020 to 7/3/2020 ...

@jan-k - I've moved your post to it's own thread, instead of it being off-topic in the previous thread.
For info @BartButenaers

1 Like

The format of the date should be in [mm/dd/yy]. I've tried, no problem on IE and Edge, except for the chrome.

On the original error message, chrome complained about the common name mismatch. But what is the error when you navigate to htts://wtp088089:1880 ?

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.