Path to 'httpStatic' on Opto22 Groov RIO

I can't seem to get the path to 'httpStatic' figured out using the Node-RED that comes pre-installed on the Opto22 Groov RIO... I've setup and used 'httpStatic' many times on the Node-RED installs I've done on Raspberry Pi's and Windows Server without issue.

The one difference I see in this pre-installed setup on the Groov RIO is that it is using...

httpRoot: '/node-red'

...and I have 'httpStatic' set as shown below...

httpStatic: '/home/dev/secured'

The Node-RED UI is available at (I generically inserted 'ip_address' for this post)...


I've tried to access the png file (which is located in the 'httpStatic' path) I want to display at...


...but I just get a 404 Not Found / nginx/1.15.2 error message.

Oh, and yes, I have restarted the Node-RED server after updating the settings.js file... you can see the top of the log file after Node-RED starts back up and everything looks ok.

Welcome to Node-RED
6 Jan 00:41:06 - [info] Node-RED version: v1.1.3
6 Jan 00:41:06 - [info] Node.js version: v10.16.3
6 Jan 00:41:06 - [info] Linux 4.19.37-rt19-g3819971626 arm LE
6 Jan 00:41:22 - [info] Loading palette nodes
6 Jan 00:42:18 - [info] Dashboard version 2.26.1 started at /node-red/ui
6 Jan 00:42:22 - [info] Settings file : /usr/share/nxtio/services/node-red/settings.js
6 Jan 00:42:22 - [info] HTTP Static : /home/dev/secured
6 Jan 00:42:22 - [info] Context store : 'default' [module=memory]
6 Jan 00:42:22 - [info] User directory : /home/dev/.node-red
6 Jan 00:42:22 - [warn] Projects disabled : set editorTheme.projects.enabled=true to enable
6 Jan 00:42:22 - [info] Flows file : /home/dev/.node-red/flows.json
6 Jan 00:42:22 - [info] Server now running at
6 Jan 00:42:22 - [info] Starting flows

Does anyone have any ideas on this?

Am I missing something obvious?

Ah, was about to suggest you post this on the Opto22 forum, but see you have already done that.

I would suggest that Opto22 forum will give the better response being Opto22 oriented, especially as you have found that it worked OK on Raspberry Pi's and Windows servers.

Sorry, I can't help in this case, my setup is Raspberry Pi, Node-Red and PAC R1 so wouldn't really relate. (Will keep an eye on your Opto22 post.)

Best of luck,
Colin J

This question was addressed on the Opto22 forums...

1 Like

Excellent, thought Beno would get on the case as he is a Node-RED evangelist!

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.