Problems by accessing http static path

Hi Guys,

I really tried to find the solution to my problem myself, but for some reason I do not understand what could possibly my problem.
So what I added to settings.js
httpStatic: '/home/christian/nodered/public/'
Restarted node-red for sure and also tried different folders till now, none with success working.

My aim is to access a subfolder e.g. '/home/christian/nodered/public/birdbox/' where I've located some images:

tying to access from the same machine (used in a template as image source):
does not work for me.

via Machine IP from another machine, which should also work:
gives "Cannot GET /birdbox/image.jpg" as response.

I am really somehow stuck on that because it seems that I have troubles by using the httpStatic folder, which should be a straightforward task.

Thanks for any advice,
best regards Christian

Can you post an excerpt of your settings.js around the line you have changed please.

Are you sure you did not mean to use '/home/christian/.node-red/public/'?

[Edit] Also stop node-red and restart it in a terminal. The startup log will show you how httpstatic is configured.

Ok, thanks so much Colin!
I was not aware of that - somehow I managed to modify another settings.js of node-red stored somewhere else in the system.
Since I was not using the start function, I was not aware of using the wrong settings file.
I modified the correct settings.js and then saw the correct path when starting node-red again.

Thats it, works like a charm now,

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.