Ping returns not reliable data - why?

Hello All!

A fresh install of NodeRED 2.1.4 at Ubuntu 18 LTS. It seems that it works but...

If I use ping node (this one node-red-node-ping (node) - Node-RED) or config ping (this one node-red-configurable-ping (node) - Node-RED) I get very wierd results when I ping some devices at my own network. I can receive values like 0.452 as well as 238 from the same device.

And if I ping the same device from Ubuntu terminal - I get normal results like 1.85 with deviation 0.5.

What can be wrong? I don't use Ubuntu Snap, Docker or everything.

Tried to use Advanced Ping the same result. It gives more or less correct results. But then provides bad results like 224 ms.

PS. I use english version of OS.
PSS. I did a small investigation. Review the code of the node, found the command promt for Linux. Try to execute in in terminal.
If I use ping -n -4 -w5000 and it pings without any stop then I receive good ping results. But if I run several times ping -n -4 -w5000 -c1 in a raw then I receive very different results including these strange and large responses like 224.

As you have found the node just calls the underlying operating system ping command, and we just report what it says, so no idea why Ubuntu is behaving like that for you.

Yes, I've found that there is something wrong within my local network. Trying to understand that.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.