Possible defect: Subflow Categories with '#' in name - cannot delete


I want to see if anyone else can recreate this. I believe it is an issue but maybe just my installation.

I created a new Subflow category (Edit Properties | Categories) called 'Data Blocks #States'. Note the hash sign - I think that is the issue. I added a couple of subflows to this new category but it did not really display properly - everything after 'Data Blocks' was missing in the title. Looked like it treated the '#' as a terminator or something.

So - I thought I'd delete that 'bad' category.

Normally, once you delete / remove the last subflow from a category the category automatically disappears. Now, no matter what I do, I cannot get it to disappear. I think it is invisible and subflows are still 'in' that category.

The category does not appear in the list on the left-nav menu (true - so it 'looks' like it was deleted).
But when using the 'Appearance' control page the item is still there:

BTW: the 'Done' red button does not work either - you HAVE to click 'Cancel' to get out of this screen.

Perhaps someone could let me know which file to edit to clean up this extraneous category?

I tried enabling 'PalleteCategories' in settings.js - no improvement. Forcing it to 'paletteCategories: ,' did nothing either.

where isn't it displaying properly?


I don't know if it is poor form to reply to myself...

I solved the issue.

Edit the 'flow.json' file (of your project) and search for occurrences of the problematic entry (in this case: "Data Blocks" and all occurrences with the "#" character. Replace with something with something.

Reload your project. Fixed it.

I think there is a limitation of using any special character in this feature. Tried brackets "( )" and this seemed problematic as well.



Ha, that was just what I was going to tell you to do!

Hi zenofmud,

Glad to hear from you - I've seen your name in multiple places all over Node-RED.

Glad my feeble brain was able to solve something even if it took a couple of hours.

I appreciate the response and wish you well.



1 Like

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.