Postgrestor node does not give any output msg

Guys,

I'm facing a strange issue on a new Node-Red setup.
It used to use postgrestor many times on many setup, but on that new one, postgrestor node does not give any output msg.

What I've already checked:

  • Downgrade Node-Red to match a version a already use and whoch works fine this Postgrestor, but nothing change
  • Complete uninstall of Node-Red and porject files, then steup again with only Inject + Postgrestor + debug node, but nothing change
  • I tested by PostgreSQL DB access, and it works with local commands, remote PGAdmin and even remote Node-Red with Postgrestor

Now I try to find a way to trace what happens into the node, but I don't get anything.
Does somebody have to feedback about such an issue, and a way to proceed?

Thanks by advance.

Update:
I also tried using node-red-contrib-re-postgres, and the result is the same...
Does it means taht the problem is deep into a common sub-node?

FWIW, I have no issues with node-red-contrib-postgrestor-next and @digitaloak/node-red-contrib-digitaloak-postgresql contrib nodes.

Hi Steve-Mcl,

Thanks for the feedback.
Same for me on other machines. And even same to connect that machine BD from another machine running Node-Red.
This makes me crazy..!

So I continue investigating this blocking use.

All my tests confirm that the PostgreSQM BD is OK since I can access it locally (command line) and remotely (PG-Admin and even another Node-Red instance using postgrestor).

That means the problem is located in that deployment, into Postgrestor and its dependencies.
As a reminder, the symptom is that Postgrestor node does not retrun any msg, whatever the BDD credentials ares (correct or not).

In addition, I've tested several other PostgreSQL nodes like node-red-contrib-postgrestor, node-red-contrib-postgrestor_next, node-red-contrib-postgrestor-variable and node-red-contrib-digitaloak-postgresql, but nothing change at all.

I'm far from a skilled nodejs developer, but looking at hte postgrestor node files shows me that they all use the same dependencies.
And I'm not able to get traces of what happens into them.

Is there some Node-red Prophet like @knolleary or @dceejay (I see that you are very active :slight_smile: ) to help me about how to get info from the route cause?

Many thanks by advance...

sorry - I don't use postgres at all

Thanks, @dceejay, for taking time to answer me.
I understand that you do not use this particular feature, but I'm also looking for tricks to get logs of what the nodes (and dependencies) are doing. But even if I config log level to the maximum (from settings.js), I get nothing more neither in syslog nor journal.

Any advice is welcome :slight_smile:

Well,

I've found a by-pass solution: since the only difference was nodejs version, I tried to downgrade it to a known compatible one, and it works... !

As I remember, the faulty nodejs version was 14.3.0.

Thanks again anyway.

Have you tried node-red-contrib-flogger (node) - Node-RED

Yes, I tried it a couple of minutes but I was just able to log data between nodes (like I saw in right side debug window), not into the nodes.

I said in my solution post above, it seem that postreSQl dependency nodes present an incompatibility with nodejs.
No time and no skills to to have a deeper look, I will satiffy myself to dowgrade it.