Problem accessing external website

Hi guys,
i have a website that is accessable from the internet
this works great !!

but if i running this config it still gets this message
msg.payload : array[1]
0: "

Error #401: Unauthorized


i tried all the options in "use authentication" but nothing is working
can someone help me here ??

many many thanks in advance

[{"id":"d62d3350.171db","type":"inject","z":"2e50eaad.878196","name":"","topic":"","payload":"","payloadType":"date","repeat":"","crontab":"","once":false,"onceDelay":0.1,"x":180,"y":420,"wires":[["3bf52f17.04cf6"]]},{"id":"66f82665.d9b308","type":"debug","z":"2e50eaad.878196","name":"","active":true,"tosidebar":true,"console":false,"tostatus":false,"complete":"false","x":720,"y":440,"wires":},{"id":"3bf52f17.04cf6","type":"http request","z":"2e50eaad.878196","name":"access the site","method":"GET","ret":"txt","paytoqs":false,"url":"","tls":"","proxy":"","authType":"","x":290,"y":520,"wires":[["d5dbcb11.d7fe08"]]},{"id":"d5dbcb11.d7fe08","type":"html","z":"2e50eaad.878196","name":"","property":"payload","outproperty":"payload","tag":"html","ret":"html","as":"single","x":360,"y":620,"wires":[["66f82665.d9b308"]]}]

Hi @menno

for future reference, please have a read of this post that explains how to share code in the forum properly.

The HTTP Request node doesn't support providing username/password as part of the url, you have to provide them separately in the node's configuration. You say you've tried the 'use authentication' options, but the flow you've shared doesn't have it enabled.

Edit the node and tick the 'Use authentication' box. Make sure 'basic authentication' is selected, then enter your username and password. Don't forget to remove the values from the url as well.

If that still doesn't work, reexport the HTTP Request node (we don't need the whole flow) and share it here. Any credentials such as username/password will not be included in the export, but we'll be able to see how else the node is configured.

ok thanks
completely setup a new flow

[{"id":"fe770289.13a3f","type":"http request","z":"2e50eaad.878196","name":"","method":"GET","ret":"txt","paytoqs":false,"url":"https://intranet.XXX.xx/ws2/Reports/hostmonitor-bad.htm","tls":"","proxy":"","authType":"basic","x":440,"y":460,"wires":[["3a01e2b.36e8c1e"]]}]

i get :

Error #401: Unauthorized

i hope you guys can help me
i know for sure that the password is OK , because i use it everyday :slight_smile:

but i want to make it work with the secure setting (https:/....)

Potentially relevant question: if you are connecting to an intranet page, does it use a valid certificate for outside-of-local usage or self signed or anything in between? The node could maybe struggle because of that too.

ok i swtched everything back to orginal state , but still this URL does not work
If i put this URL in my google browser IE or Edge it works

i use a HTTP-Request node and a debug nog to see the output
still unauthorized ....
if i use the basic or digest authentication it also still does not work.

what i am doing wrong here ???
thanks in advance

I think that the page(s) in question are trying to have a security handshake that is not being captured. This could be as simple as it needing to set a cookie dynamically.

Without knowing what server is providing the Intranet, it is hard to know what it will be doing.

Can you try it using wget from a command line?

thx guys ,
i opened up the httpS to http because its an internal website.
This works.
I will leave it like this
thanks for all the ideas and help