Problem Installing node-red-node-pi-gpiod

When I try to add the pi-gpiod node from the web interface I get an "Error Install failed" message, with the following message in the event log:

"added 15 packages from 3 contributors and removed 302 packages in 128.052s"

I have trouble with node red and end up reinstalling.

when I try to install it from the command line

npm install node-red-node-pi-gpiod

I get the following:

`npm WARN saveError ENOENT: no such file or directory, open '/root/package.json'`

`npm WARN enoent ENOENT: no such file or directory, open '/root/package.json'`

`npm WARN root No description`

`npm WARN root No repository field.`

`npm WARN root No README data`

`npm WARN root No license field.`

`+ node-red-node-pi-gpiod@0.4.0updated 1 package and audited 24 packages in 16.736s found 3 low severity vulnerabilities run \` npm audit fix` to fix them, or `npm audit` for details`

I tried the audit but it tells me audit No package.json found: Cannot audit a project without a package.json

any advice to next steps?

You need to cd to the .node-red folder before running npm

Ok, just one problem. I don't see that directory in ~ I see a node_modules but I assume that is because I ran the previous npm command there.

I am using dietpi and it had an install script to install node red as a service.

I tried to find it

`find / -type d -name ". node-red"'

No dice.

Thanks for the help

What script did you use to install node-red?

try
find / -type d -name .node-red

(you had a space between . and node-red )

1 Like