Raspberry pi on Bookworm

my Raspberry is running Raspbian Bookworm. I was about to install Node-RED but I have found:

If you are using Raspberry Pi OS, Bullseye is the currently supported version.

When is the Bookworm compatibility expected to be released? Please advise

It is fine on bookworm. Docs must be slightly behind :slight_smile:

1 Like

Thanks for the good news? Shall I install it with the usual script?

bash <(curl -sL https://raw.githubusercontent.com/node-red/linux-installers/master/deb/update-nodejs-and-nodered)


Yes. That should work fine.

Thanks, with or without sudo?

Must be without

Are there any known issues e.g. with Pi specific nodes ?

None that have been reported

The RPi-GPIO python library, that NR depends on, doesn't work on a Pi5 using Bookworm.

1 Like

really ? oh joy.
Can you raise an issue with any more details?
Is it just the Pi5 ?
What are they replacing it with ?

All I know is that it was a big issue in the Pi eco-system when the Pi5 was launched.

I've not kept abreast of developments sorry :frowning:

It's very difficult to get an Rpi5 at the moment. Was lucky and was able to get one. With the Rpi5, access to the GPIO is different. I'm in the process of adapting my nodes for the Rpi5. But unfortunately there is little information and examples about it.


I assume you've seen this?


Don't know if it helps but at least seems to explain the background?


I've just tried the official install script on RPi bookworm 64bit.

Of course after installing npm manually everything worked fine,
but it's interesting why the script isn't checking if npm is installed?

at the end of the install this happened in my SSH terminal:

  Would you like to customise the settings now (y/N) ? y

Node-RED Settings File initialisation
This tool will help you create a Node-RED settings file.

? Settings file ‣ /home/pi/.node-red/settings.js

and it just stopped there. Did not get the cursor back.
No settings.js file was created.

My bad ...

the script was WAITING, so I edit that line and press Enter !
+1 echo would help a lot. Like:

Edit following path and filename, than press Enter:

Well - obviously it IS checking - and not finding it... which usually only happens if nodejs is not correctly installed as npm is part of the nodejs install. How did you install nodejs ? and which version of npm did you end up installing (and how?)

I did no such thing.
the NR script has installed it for me.

sudo apt install npm

As I've noted:

  • After that the NR install script WORKED.

can you do me a favour and show the result of

dpkg -s nodejs | grep Version && npm -v


pi@oh:~ $ dpkg -s nodejs | grep Version && npm -v
Version: 18.19.0+dfsg-6~deb12u1

yeah that is the one from the debian repo not the nodesource repo, which doesn't come with npm...). Not sure why that got installed in the first place.