Raspberry pi Install script not working

Hi, I tried installing nodered locally on my new raspberry pi 4 B and the provided Github install script does not work. The pi seems to "think" for a while when the script is run but returns to command prompt with no indication of what went wrong. I did update and upgrade my pi Os first before attempting to install nodered.

What am i missing?

Hi srikumarc,

Can you explain exactly what you did to run the script?
A screen capture might help diagnose it too (even if the script exits without printing anything)

Do you have a file /var/log/nodered-install.log? There may be clues in there.

Hi Jbudd

This is copied from my screen

srikumar@raspberrypi:~ $ bash <(curl -sL https://raw.githubusercontent.com/node-red/linux-installers/master/deb/update-nodejs-and-nodered)

srikumar@raspberrypi:~ $

OK, that certainly looks right - no sudo, running from the home directory.

  1. What about the log file?
  2. Is your user name "pi" or something else?
  1. The Var folder does not contain any log pertaining to Nodred installation
  2. No. myuser name is srikumarc
  1. I meant var/log folder

Does your username have sudo ability?
Edit: - I see you do have sudo.

I have never seen the script exit silently, maybe @dceejay might know what's going on.

If I had this problem, here's what I would do as an experiment. Never tried this.

1 Download the script curl -sL https://raw.githubusercontent.com/node-red/linux-installers/master/deb/update-nodejs-and-nodered > nrinstall
2 Edit the script to remove the code which throws away output sed -i 's|>>/dev/null||' nrinstall > test
3 Run the edited script bash ./test

If you are lucky there will be an error message, or possibly lots and lots of output.

sorry jbudd, I have limited ability in scripts editing !

I am just now taking baby steps out of the windows world !!

Maybe not a good idea changing the script, let's see why it's not working first.
Are you using this install script - Running on Raspberry Pi : Node-RED ?
What operating system have you installed?

Shrug. I'm away from my computer for a while anyway.

Ye. That is correct

Can't read that on my phone, please type it instead of screenshotting!

As Paul says, please copy/paste output here rather than screenshot, where possible.

What does this commands show?
curl https://raw.githubusercontent.com/node-red/linux-installers/master/deb/update-nodejs-and-nodered
If it outputs lots then just the last few lines will do.

@jbudd We did have a similar report of no output at all just a few weeks ago, but I can't immediately find it.

'srikumar@raspberrypi:~ $ cat /etc/os-release
PRETTY_NAME="Raspbian GNU/Linux 11 (bullseye)"
NAME="Raspbian GNU/Linux"
VERSION="11 (bullseye)"

srikumar@raspberrypi:~ $

connection refused !

srikumar@raspberrypi:~ $ curl https://raw.githubusercontent.com/node-red/linux-installers/master/deb/update-nodejs-and-nodered
curl: (7) Failed to connect to raw.githubusercontent.com port 443: Connection refused
srikumar@raspberrypi:~ $

You have a networking issue of some sort. Can you issue the curl command from your PC? It won't do any harm as it just fetches the file and displays it.

[Edit] Another couple of questions.
Are you using a VPN at all?
What does this show
Does it show the correct local time and timezone?

Got locked out of the forum for 24 hour being a new user and having posted messages in excess of the allowed maximum yesterday. Hence the delayed reply as below;

Tried it from my PC. got the following message


I am not using any VPN

Yes, "date" command shows the local time correctly

Your observation about networking issue proved correct. Something seems to be wrong with my ISP, gateway or my router. I tried connecting my pi using mobile hotspot and the installation script worked but there is a new problem. It stopped after the second (y/n) step with the message below.

Running Node-RED install for user srikumar at /home/srikumar on raspbian

Node-RED v3.x no longer supports Nodejs 12

You can force an install of node 14, 16 or 18 by using the --node14, --node16 or --node18 parameter.
However doing so may break some nodes that may need re-installing manually.
Generally it is recommended to update all nodes to their latest versions before upgrading.

If you wish to stay on nodejs 12 you can update to the latest Node-RED 1.x or 2.x version by adding
--nodered-version="1.3.7" or --nodered-version="2.2.2" to that install command. If in doubt this is the safer option.
Please backup your installation and flows before upgrading.

Exiting now.

Installation is getting interrupted. can you please give me a solution? I have run update and upgrade command already and rebooted my pi.