The installation script has no output in raspberrypi

Hi, I tried installing nodered locally on my new raspberry pi 4B and the provided Github install script does not work.I followed the official docs,make sure git curl build-essential works successfully.But when I ran the installation script, there was no output.sudo is not used

lmy@raspberrypi:~ $ bash <(curl -sL
lmy@raspberrypi:~ $

At first I thought it was my installation problem because I was a novice. But I used a new sd card with a new raspberry pi os(64-bit) and still had the same problem.

I found the problem in the forum and did what @jbudd said.

1 Download the script curl -sL > nrinstall

I came up with the file nrinstall, but it doesn't have any content

The output in the shell is as follows

lmy@raspberrypi:~ $ curl -sL 11 > nrinstall

lmy@raspberrypi:~ $

lmy@raspberrypi:~ $ curl
curl: (7) Failed to connect to port 443 after 31 ms: Couldn't connect to server

Cat /etc/os-release :

PRETTY_NAME="Debian GNU/Linux 12 (bookworm)"
NAME="Debian GNU/Linux"
VERSION="12 (bookworm)"

Thank you for your help and attention.

Welcome to the forum @lmy235638

What does this command show? I think you may have a network issue.

The command I suggested in that thread is probably not sensible to use in every case, though it can't do any harm.
If the file nrinstall exists but has no content it does indeed suggest that your Pi has a network problem.
It might have been a temporary outage. Try the standard installation command again and let us know if you still have problems.

I really appreciate your answer.I have successfully installed, it is a problem caused by the network, I am from China
Use the vim /etc/hosts command to open the hosts file on an unreachable machine and add the following:

Then modify the image source according to the official
linux-installers/ at master · node-red/linux-installers (
Finally, run the bash command to successfully install

I had suspected it was a network problem, but the script didn't have any output that bothered me all afternoon.
Thank you all and the forum!

It's a network problem. I just posted the solution above. Thank you for helping me with your answers before the forum, and thank you very much for your answers this time

The correct solution is use a DNS service that is able to provide the ip addresses. Perhaps that solution is not available in your country.
IP addresses can change, which would stop the script from running again. That is why DNS is used to map domain names to IP addresses.

Here in the UK we hear about state control of access to the internet in China.

I'm glad you found a way to install Node-red, which is surely an innocent programming environment!

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.