Install NR using the Script does not work

I have a brand-new Raspi 4 with Raspbian Buster running and want to install Node-Red now.
Unfortunately the script

bash <(curl -sL

does not do anything.
This is how it looks on my machine:

pi@raspberrypi:~ $ bash <(curl -sL
pi@raspberrypi:~ $

Any ideas what woring with my Raspi ?


Is your internet access ok?
What happens if you open run

curl -sL

Which should fetch the script and run it. If it says that curl is not found then
sudo apt install curl

internet works fine, yes

curl is already the newest version (7.64.0-4).

pi@raspberrypi:~ $ curl -sL
pi@raspberrypi:~ $

I have set up a completely new SD card with raspian buster for my raspi4 now ... same behaviour as before
If i start the script nothing happens
is there any kind of logfile or anything I could check ?

If you've downloaded the script, you could look at what it does and step through it manually. It is odd not to get any output from it ... so not sure if it would have gotten as far as logging anything yet. May need input from @dceejay when he's next around.

Can you ping from the pi?

I have just done a quick test and it seems that curl just returns without comment if it cannot access the url specified. So I think that does mean that for some reason you cannot access that site. As @edje11 suggested the next test is to see if you can ping it.

Still odd - as the script does try to check internet connectivity and should print out if that fails...

If curl can't connect to download the script then nothing in the script to check the connectivity will make much difference :slight_smile:

Yes, I can download the script manually without any problems (from my local PC). I can ping the server from the raspi. This could not be the issue

pi@raspberrypi:~ $ ping
PING ( 56(84) bytes of data.
64 bytes from ( icmp_seq=1 ttl=50 time=170 ms
64 bytes from ( icmp_seq=2 ttl=50 time=169 ms
64 bytes from ( icmp_seq=3 ttl=50 time=169 ms
64 bytes from ( icmp_seq=4 ttl=50 time=169 ms
64 bytes from ( icmp_seq=5 ttl=50 time=170 ms

Unfortunately I am not able to execute the scripts steps manually ... I am not that deep into linux and commandline

doh ! - good point Colin...

If you have managed to download it - can you just try running it locally - It should at least then report why it's failing... (fingers crossed)

but meanwhile I solved the issue by manually installing NPM and NODE using this guide:

it works now with most actual versions - it seems I was expecting too much from linux :roll_eyes:

I do not know how to download and execute it manually on the pi
I was able to download it to my windows pc without any problems

Run the curl command without the -sL arguments. That will download the script into the current directory. You can then try running it manually.

seems to be a SSL issue !?!?

pi@raspberrypi:~ $ curl
curl: (60) SSL certificate problem: unable to get local issuer certificate
More details here:

curl failed to verify the legitimacy of the server and therefore could not
establish a secure connection to it. To learn more about this situation and
how to fix it, please visit the web page mentioned above.
pi@raspberrypi:~ $

You had similar ssl issues trying to update npm. So yes, suggests there are issues with your pi's SSL handling. Have a search for these errors to find out how others have fixed it.

(random thought - is the clock correct on your Pi - sometimes if the clock is wrong then the cert will be "out of date")

hm ... datetime was set to UTC instead of CET, but it did not solve the issue

If you've had at least 2 sets of issues related to SSL/TLS, you are almost certainly going to get more. Better to sort that out now even if it means setting up from scratch because it will only get harder later on.

1 Like